Why my FDTD simulation got stuck at Meshing and cannot go ahead?

#1

I am running FDTD simulation but the software got stucked at meshing step (30mins+ without progress). But if I copy the same file to another computer, it took me only 5 mins to finish the simulation.

computer in which the simulation worked:
image
computer in which the simulation got stuck:
image Voxel_Hemi_400nm_LabQ.fsp (9.0 MB)

#2

Hi @qliu1

Are you using the same product version in both machines? Are you able to run any other simulation files in the workstation that failed?

Please monitor the RAM and CPU and make sure that you have resources available for the simulation (i.e. CPU and RAM are free) and keep me updated with the results. I am inviting @lyap who has more expertise in this regard.

#3

@qliu1,

I was able run your example simulation on my machine, but it took about a couple of minutes on the meshing stage.

I tried using different job launching presets and using 4 or 6 processes.

On the machine where it took 30 minutes to run and using only 4 or 6 processes, try to run our example simulation (nanowire.fsp or paralleltest.fsp) from the KX post:

-Lito


Please mark this as resolved if the issue has been fixed. Thank you

#4

My laptop runs FDTD 2018a (8.19.1541) on Win10, and my PC runs FDTD 2019a r3 on Win7. It is with FDTD 2019a this simulation stuck. Actually there are two cylinders and a base plate in my simulation. The two voxel-based cylinders are imported from a stl file. But if I disable the stl cylinders and replace them with the build-in cylinders, the simulation runs well. I am wondering if there are some compatibility problem of 2019a version with stl file…Pillar_400nm_test.fsp (336.0 KB)

#5

Dear Iyap, thanks for your reply. I tried to changed the resources from Microsoft MIP to Remote: MPICH2. And it gives the following error message:
WeChat%20Image_20190320154554
when I use other MIP, the problem remains. I also changed the processes and threads, finding no differences. If I disable the stl structure then it worked well.

#6

Please use the same versions on both your machine. There has been a lot of changes between these 2 versions. I would recommend using the versions that are available for download from our website. These are the versions we support.

Please completely removed the previous installations first.

-Lito


Please mark this as resolved if the issue has been fixed. Thank you

#7

Thanks. I tried in another machine with 2019a and it runs well. I assume the best way should be use the latest version of Windows as well as FDTD.

closed #8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.