Why are there only small amount of effective indices if the waveguide is surrounded by PML?


#1

I simulated the same waveguide surrounded by metal and PML, respectively. There are a lot of effective indices in the metal case, while there are only two effective indices in the PML case (corresponding to the guided mode).

Is there any potential step to throw away some effective refractive indices in the PML case?


#2

Hi @X.Lu.1
Could you please upload the simulation file? Do you want to plot only the modes of the waveguide? Do you use a source? If you do not use a source please don’t use PML boundaries. You can use only metal boundaries. PML boundaries are used to absorb the light from the source.


#3

Thanks for your reply.
I just want to profile the modes of the waveguide without a source. However, the waveguide I want to simulate is an open waveguide. So I think the PML is necessary.


#4

Hi,

It is usually possible to use metal boundary conditions for the FDE solver unless the modes you are looking for are leaky, as discussed here:
https://kb.lumerical.com/en/index.html?ref_sim_obj_starting_with_metal_bcs.html

When you use PML boundaries, some modes may be automatically removed from the mode list based on the fraction of fields contained in the PML region. This can be set by setting the “automatically remove pml modes” option which can be accessed from the “Advanced options” button at the very bottom left of the “Eigensolver Analysis” window.

The specific definition of the PML removal threshold can be found here:
https://kb.lumerical.com/en/index.html?layout_analysis_eigensolver_advanced_options.html