Waveguide TE mode on Interconnect

interconnect

#1

Hi,

When I compared the design waveguide of mine with example of biosensor circuit (https://kb.lumerical.com/en/index.html?applications.html), the outcome(result) for power transmission totally different. What I mean, I couldn’t able to get sin waveform or although similar to sin waveform outcome. Certain parameter like frequency I set it.

I would like to get advice & guidance. What the effect that I cannot get the waveform. Is it because of waveguide design or the parameters.

Outcome of my design in figure below:-

Kindly refer to attached file.
waveguide_20160606.icp (464.4 KB)

Hope to receive your feedback. Please guide.

Thanks for your support.

Best Regards,
Kalai


S-Parameter (how to define the "abs and angle")
#2

Hi @kalaivani.tarumaraja,

It doesn’t work because the settings for the waveguide element and for the modulators are not reasonable. If you may notice, the default values for the elements when you just dragged and dropped them from the element library are not always reasonable values and you have to tune them based on your design requirements. For example, the effective index and group index of the waveguide element and the length of the modulators are not reasonable values in your case. In your case, the length of the modulator should match the length of the waveguide.

Change these parameters based on your own design requirement and you should be able to see reasonable results.

I hope this could help :slight_smile:


#3

Hi Guanhui,

I understood**. Thanks so much for your advice. It’s really helpful.**

I modified my design base on my design requirement. I can see the changes on my result on “Re & -Re”. But, the output for “Abs2” still show as same output as previous figure(post).

When I copy the element s-parameter from biosensor circuit example (https://kb.lumerical.com/en/index.html?applications.html) and import to my design, I can see my output “Abs^2” slightly similar as example output.

Please have look on figure below:-

Can I know how to modify the s-parameter (matrix)? I only able to add the rows. The column, I don’t know how add it.

S-parameter matrix
Element import from library : [1 3]
Example biosensor: [50 9]

Thank You.

Best Regards,
Kalai


#4

Hi @kalaivani.tarumaraja,

Yes, by default the s-parameter follows the 3-column format if you edit it in the matrix editor. For the file formats, please refer to the KB page Optical S-Parameter (SPAR) in the Implementation Details section.

You can modify the s-parameter file to the format you want and then load it to the element. However, in any case, you cannot modify the number of columns of the s-matrix in the matrix editor.

I hope this could help :slight_smile: Let me know if you have any difficulties reading this.