Voltage sweeping was abandoned


#1

Hello,

My PN junction simulation was abandoned when I tried to sweep a few voltage points at -4V, -2V and 0V.

At the beginning, when I performed the simulation at each fixed value of -4V, -2V and 0V, the simulation runs OK without any problem (but it is really slow, compared with the case when I ran the tutorial example). Then I switched to the sweeping mode, the simulation runs OK at the first voltage point but was abandoned at the second value. The error message is as follows,

USSRV0086(process 0): The program terminated due to an error: The simulated result is incomplete. Please review the log files for details.
USSRV0086(process 0): Error: there was an unknown parallel error. The error code is 9002, the process number is 0

I noticed that someone has reported similar error message before, which was solved by extending the doping volume. But it might not be the case here since I can run the simulation without problems at a fixed voltage.

Would you please advise what is the problem here? Thank you. I have also attached my codes here.modulator_setup_parameters.lsf (3.6 KB)
modulator_setup_device.lsf (8.7 KB)

Regards,
Jian


#2

Hi @jian.wang1, I took a quick look at your script and it looks like the problem is that your voltage step size for the sweep might be too large. You have a step size of 2 V that might be too large for the solver to converge on the 2nd bias step (the CHARGE solver uses the result from the first bias step as a guess for the next step so if the step size is too large then the guess becomes a poor one and the solver fails to converge. If you make the step size smaller (say 0.5 V or a bit smaller than that if necessary) then the simulation should work fine (given that it works for the different bias points separately).