Unexpected program termination during modeling 2D material


#1

Hi,
I am interested in the optical devices based on 2D materials. For modeling 2D material, I am trying to import the sampled data for conductivity by using the “sampled 2D data” option in Material Database.
Whenever I try to fit sampled data in Material Explorer after creating new material and importing data from text file, however, I repeatedly got error message saying “The program terminated due to: unknown error Please contact Lumerical technical support for assistance” and Lumerical was terminated automatically.
I have any idea of why this happens.

Attached is the text file containing the real (column 2) and imaginary (column 3) parts of conductivity as a function of wavelength (column 1), which I used to create new material.

Would you please let me know how to solve this problem??

2d.txt (16.8 KB)


#2

Hi @leex9020

When you try to import the data, you need to choose the units for your resistivity, either Ω or Ωm. If you select the Ωm, you need to define the layer thickness, or otherwise the program will crash when you want to fit the data. However, if your unit is Ω, you should be safe plotting the data. Please see the figure below:

I hope this could solve the problem.


#3

Thank you for your reply.
However, as I said before, the data I used was not resistiviity but conductivity.
So I chose the first option in the figure you attached.
Or Are you saying that I should convert the conductivity to resistivity?


#4

HI @leex9020

The same solution holds for this case as well.

If you use conductivity (S/m), you need to fill the box for the material thickness otherwise the program would crash. If your conductivity data has the unit of S, you don’t need the material thickness.


#5

Hi Behzad,

I never know that I need to fill the box! Thank you so much for your help.
I followed your suggestion and it seemed to work nicely at the first time.
When I gave it a try with other file, however, I faced with unexpected
program termination even though I filled the box for thickness.
Attached is the data file for the conductivity of optically anisotropic 2D
material, meaning that it has x, y, z conductivity components.
Data fitting works well for x, y axes but not for z axis.
Do you think that it is because z component is zero?

Thanks again. I hope to hear from you soon.

Regards,

In-Ho

BP_nl8mu03_sigma.txt (53.3 KB)


#6

Hi @leex9020

I am glad that your previous problem is solved.

As you said, it seems to be the the result of having arrays of zero. I tried to import arrays of 1E-8 for the z-axis rather than zeros and it solved the problem. This is a small number and is four orders of magnitude smaller than x and y axes, and is a reasonable assumption. Material fit works now!

Also, even the fits are not looking good, the error bars are minimal (in the order of 1E-9) and shouldn’t cause any problem.

I hope this solved the problem.


#7

Behzad,

Thank you so much. That solution worked well.
I could pit x y z components and run simulations.
Thanks again.

Best,
In-Ho


#8