Unable to start license manager on Debian (Ubuntu) Linux

linux
ubuntu
licensemanager

#1

I tried the above instructions on Debian and was also successful in installing both the license manager and FDTD Solutions. However, I cannot start the lmadmin and just get a segfault

jan@ramuno:/opt/lumerical/lumerical-flexlm$ ./lmadmin
Segmentation fault

In this (Installing on Ubuntu - Alien freezes) article ppham says, that the license manager must run on a supported platform. However, no reason is given. So did you really get the license manager running on Ubuntu and do you have any suggestions on this segfault? I installed gcc-multilib and lsb-core.


How to install on Ubuntu (new link below)
#2

Try the following:

ps -ef |grep lmgrd

and

ps -ef |grep lmutil

We will get an output similar to the one below.

user@hostname:/opt/lumerical/lumerical-flexlm$ ps -ef | grep lmgrd
root 3738 1521 0 13:23 pts/9 00:00:00 ./lmgrd -c /opt/lumerical/lumerical-flexlm/licenses/LUMERICL/start.lic -logfile test01.log

Then we can kill the process that is running the license manager - should be the first process on the list (as shown on the example above). If you are running more than 1 license file, it will show additional processes with their corresponding license file.

Before shutting down the the license manager, please make sure that no one is accessing the license(s).

sudo kill 3738

repeat the above command in killing the other processes - as needed

If only one line is shown when executing ps -ef | grep lmgrd

lito 2501 2439 0 13:55 pts/0 00:00:00 grep --color=auto lmgrd

Then, do the following;

sudo /opt/lumerical/lumerical-flexlm/lmutil lmdown -all
sudo /etc/init.d/lumlmadmin start

Then we can confirm if the license manager is running by;

http://localhost:8095

If the “Vendor Daemon” is not running or down, we can start it manually as outlined in the article below:
Manually starting and stopping the Lumerical Vendor Daemon using the Dashboard.


#3

Hi lyap and thank you for your answer.

I did not copy the init-script to the init.d-folder, I currently have it in /opt/lumerical/lumerical-flexlm/etc/ and found that running it essentially just executes the lmadmin program. So I am trying to get lmadmin running by starting it manually to get some more output. However, it just crashes with a segfault less than a second after starting it. So there are no lmgrd or lmutil processes running, which I could kill.

Well, in fact there is a lmgrd running, but it is the license manager of our Comsol software. Also stopping this server leads to the same result: Immediate segfault after starting lmadmin.

This is why I cannot access anything via my webbrowser at http://localhost:8095.

Do you have any other suggestions?

Best regards
Jan


#4

Unfortunately, we are unable to recreate the error you are getting.
I would suggest to use a supported OS as listed on the link below:
https://www.lumerical.com/tcad-products/system_requirements/


#5

Jan, I have FDTD and flexlm running fine on Ubuntu, so it can work on a Debian like system. You may have some dynamic library skew. Use the ldd command to see what libraries are being used by your executables. Compare it with below. Maybe you can see where the discrepancy lies. In the case of lmadmin, here are what libraries are pulled in with my (working) installation on Ubuntu 14.04.

$ ldd lmadmin
linux-gate.so.1 => (0xf77c5000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7788000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7742000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7724000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7575000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7570000)
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7567000)
libcrypt.so.1 => /lib/i386-linux-gnu/libcrypt.so.1 (0xf7536000)
/lib/ld-lsb.so.3 => /lib/ld-linux.so.2 (0xf77c6000)

Once you know which library is suspect, you can try rearranging/reinstalling things to try to make things work. You might learn something from analyzing the segfault dump. Again, it’s probably some dynamic library function on your system that’s different in some way. Pity this binary isn’t statically linked.

Full disclosure – I don’t work for Lumerical. Just trying to help.


C


#6

Hi nadovic,

thank you for your help. Unfortunately, I already used the very same library versions.

Up to now, I did not find a solution to the problem and will probably use either another machine for the license server (or integrate the license in the Comsol license server). If I find a solution, I will update my message here.

Best regards
Jan


#7

You may be missing your 32-bit libraries. On a recent attempt to install the license server on a fresh installation of Ubuntu 16.04 LTS 64-bit, I had the same segfault behavior.

I also verified that ldd could see all the linked libraries. On my system, however, I needed to update my 32-bit libraries:

apt-get install libc6:i386 libstdc++6:i386

Hopefully that helps.


#8

We have updated the Install workaround for Ubuntu,

On a clean installation of Ubuntu Server 16.10, FlexNet license manager only requires lsb.

sudo apt-get update
sudo apt-get install alien
sudo apt-get install lsb

The above commands were executed prior to the installation of FlexNet license manager.


#9

@jan.vogelsang,

Sorry I missed one aspect of your post,

I did not find a solution to the problem and will probably use either another machine for the license server (or integrate the license in the Comsol license server).

I missed out that you are running a license manager for COMSOL on the same machine.

  1. You will have to use a different license model, a Floating MAC lock license will resolve your issue. As per our KB article.
    https://kb.lumerical.com/en/install_flex_lm_integrate_lumerical_daemon.html

If you are using a Trial License for Linux, please contact us at install@lumerical.com for details on getting a Floating MAC lock license instead of the default Trusted Storage license that we issue for trial license.