Transmission Trend

Hi @mohammad.tabatabaei

Since the structure is periodic along x- and y-direction, you can reduce the x-span of FDTD similar to the KB example. Increasing FDTD span not only increases simulation time (which is probably why the auto shutoff level did not drop in your simulations), but also causes a large mesh aspect ratio close to PML boundaries.

Also, make sure that geometry and material properties of the paper and simulation match. Please visit the page below for some tips on performing convergence tests:
https://kb.lumerical.com/en/index.html?layout_analysis_test_convergence_fdtd.html

1 Like

Hello @bkhanaliloo,
Thanks for your kind reply.
I’ll check the points you mentioned.
Best regards

Hello @bkhanaliloo,
I have faced divergence problem in the simulation. Since I’d like to consider nonlinearity in the graphene model, I use sample data type for this material. I’ve read pages related to divergence problems and modifying the material fits in KB and followed the structures. I noticed the problem is dt stability and made some changes to the project such as changing dt stability factor or mesh aspect ratio but the problem still exists.
I also checked material explorer and noticed that real part of graphene_eps doesn’t fit. I tried to solve this problem but I couldn’t.


And here is the project:
graphene_THz_metamaterial.fsp (363.0 KB)
I appreciate any help.
Best regards

Hi @mohammad.tabatabaei

We had a long weekend here and I was sick for the last two days. I will get back to you hopefully by tomorrow.

Thank you for your patience.

Hello @bkhanaliloo,
Thanks very much for your kind reply. I was sorry to hear that. I hope you get well soon.
Dear Behzad, I have made some changes to my project and the simulation still diverges. I would appreciate if you could take a look at this project (not the one in previous post ) whenever you get better. graphene_THz_metamaterial.fsp (362.9 KB)
Also Imaginary part of the graphene_eps does not fit very well, I couldn’t solve this problem.


I really appreciate your help.
Best regrads

Hi @mohammad.tabatabaei

Thank you very much for your warm wishes, I feel better today.

I think the divergence problem, as you might have guessed it, is due to material fit. Since the make fit passive box is unchecked, material fit returns negative imaginary part for graphene which acts like a gain for this material. This runs the simulations to diverge.

I spent quite a significant time to improve the fit, but it was not very successful. Since the imaginary part is zero, here are good links to look and see how the material fit can be improved:

https://kb.lumerical.com/en/index.html?materials_creating_lossless_materials.html
https://kb.lumerical.com/en/index.html?materials_sampled_data_modify_fit.html

A good approach would be to run multiple simulations with narrower source bandwidth (instead of one broad source) and check the material fit for each simulation.

I have also modified simulation file and used small x and y span of FDTD as geometry is periodic along these directions. You can also use finer mesh over graphene material as part of convergence testing. Here is modified simulation file for your review:

graphene_THz_metamaterial_BK.fsp (369.0 KB)

Another options would to use other material models or trying 2D graphene.

Hello @bkhanaliloo,
I’m happy to hear that.
Thanks very much for your kind reply.
Best regards

1 Like

Hello @bkhanaliloo,
I made some changes to the data used in sample data material and now the simulation is stable, no divergence occurs.

Since I’d like to compare the linear response with results of another paper, I don’t change the geometry of FDTD since already it has a good agreement. In first post the linear response is attached. I checked the new geometry you suggested, the transmission trend had less similarity with paper’s result.

In next step, without changing simulation setup, nonlinear model is replaced with linear graphene. The transmission trend has oscillation in the frequency range.
Transmission
Then I changed some parameters such as kappa and shutoff value, the result was a little better but there was still oscillation in the trend.
Transmission
I’d like to know what is the source of oscillation? How can I remove the oscillation? The correct trend has two resonance frequencies around 2.1 THz and 4.4 THz without oscillation. I really appreciate any help.
Best regards

Hi @mohammad.tabatabaei

I checked your original simulation file and I think I owe you an apology. The graphene layer in your simulation has a limited width (x-span=7.5um), however I have thought that it is an infinite layer. That means that you cannot reduce the x-span of FDTD and it should follow the periodicity value. Your setup is correct, but you could simply run a 2D simulations instead of reducing the y-span.

Regarding the nonlinear simulations: Generally, the oscillation occurs if simulation stops while there is still a significant energy left in the simulations. This can occur due to poor PML absorption or early shutoff. I can take a look at your file if you please share it with me?

Thanks

Dear @bkhanaliloo,
Thanks very much for your kind reply. Don’t mention it, I had to point out the periodic BC in my post but I forgot.

Since I was using one of lumerical’s examples and it had an exact result in comparison to the original paper, I didn’t change the setup and only adjust the dimensions. I have no idea about 2D simulation.

I thought the oscillation might stem from ABC or shutoff value. So I changed auto shutoff min value to 1e-8, 1e-12 and 1e-25, but the trend was still oscillating. Then I changed kappa value to 10 and 30, unfortunately oscillation still exists.
Here is the project.It is worth noting that the intensity is increased in simulation in order to investigate the transmission .
project.fsp (363.9 KB)
project.lsf (1.7 KB)
I really appreciate your help.
best regards

Hi @mohammad.tabatabaei

I ran your simulations with a finer mesh and steep angle PML (took couple of hours in my machine to finish). I noticed that the auto shutoff level did not drop below 0.3. This means that even though you are decreasing the auto shutoff level, since simulation time is not long enough, it stops before triggering the auto shutoff. Here is the transmission results for your review:

image

You can increase the simulation time and use time monitors close to PML boundaries to check and make sure field has decayed when simulation stops. I have attached the modified file for your review:
project_BK.fsp (376.4 KB)

Also, looks like you are using sampled 3D data for graphene. Can you please elaborate why this is a nonlinear material? Here is a KB article regarding nonlinear material:

https://kb.lumerical.com/en/index.html?nonlinear.html

Hello @bkhanaliloo,
Thanks for your kind reply.

How can I increase the time simulation and check filed decays? Is there any page explaining these points?

Because I’d like to investigate nonlinear response.

I have another question, dose plane wave source and its geometry and position effect the trend? I mean for example, how the distance between the source and structure is set?

Best regards

Hi @mohammad.tabatabaei

Simulation time can be controlled from the General tab of FDTD:
https://kb.lumerical.com/en/index.html?ref_sim_obj_simulation_fdtd.html

and a time monitor can be used to capture the field as a function of time:
https://kb.lumerical.com/en/index.html?ref_sim_obj_monitors_time.html

The ripples in the spectra are due to early stop and is explained in the link below:
https://kb.lumerical.com/en/index.html?ref_sim_obj_frequency_monitors_simulation_time.html

The source region is defined by a white box and as long as the object is outside this region, you should be safe:

image

In fact we recommend to bring the plane wave source close to geometry (and leave only a few mesh cells between source and geometry) to save pulse/light travel time.

We have an online free FDTD course that covers a lot of details and I will recommend you to enrol:
Lumerical University

Hope this was helpful.

1 Like

Hello @bkhanaliloo
Thanks very much for your kind reply.
Best regards

Hello @bkhanaliloo,
Finally the ripples were removed from the transmission spectrum. Thanks very much for your help.
I just have a question about simulation time. After changesare applied to the project, it takes almost 22 hours to do the simulation and it’s too much! Is there any way to decrease simulation time without affecting the result?

Best regards

Hi @mohammad.tabatabaei

I am glad to hear that the results make sense now.

You can perform convergence testing: https://kb.lumerical.com/en/index.html?layout_analysis_test_convergence_fdtd.html

and see if changing any of the parameters will result in smaller simulation time.

Another thing that you can try is to use 2D graphene layer. I can see you had posts in this regard:
2D Graphene

Is this something that you want to do? Please keep me updated with your thoughts.

Thanks

Hello @bkhanaliloo,
Thanks very much for your kind reply.
I’ll check the converging tests to reduce simulation time.

I want to make some changes in graphene model which can not be applied in 2D model, that’s why I use 3D model.

Best regards

Hello @bkhanaliloo,

I’d like to know more about auto shutoff level. I’ve read pages related to this issue (i.e this one) and I’m a little confused.

I could finally remove ripples from the trend, but in some cases auto shutoff level is not satisfied. For example simulation time is 35000, auto shutoff level is 1e-8, the transmission spectrum has no oscillation, the log file shows that when the simulation ends, auto shutoff is 1e-5. Can I trust the data of this simulation? In fact, when the simulation is ended but this message is not shown ‘Early termination of simulation, the autoshutoff criteria are satisfied’ , and auto shutoff level in log file is around 1e-5 (larger than FDTD settings), can we consider simulation’s data reliable?

Best regards

Hi @mohammad.tabatabaei

The energy left inside the simulation region is returned at different time steps. Once this energy level reaches the auto shutoff level, the message is returned, and simulation is stopped. Once you reduce the auto shutoff level, simulation will continue until it reaches this level. Sometime you will need to increase simulation time to make sure that simulation will continue to reach this level.

Overall, an auto shutoff level of 1e-5 is enough. However, in cases where there are ripples, auto shutoff level can be further decreased until ripples are removed and results converge. Improving the PML performance (for example using different PML settings and number of layers) is another important factor to make sure that energy within simulation region is absorbed and auto shutoff level is fulfilled.

Hope this was clear and addressed your inquiry.

Hello @bkhanaliloo,
Thanks for your kind reply.
Best regards

1 Like