transmission in gold ring resoanator

fdtd
pml
transmission
simulationtime

#1

Hello,
I simulated Fig 2(a) from this article: https://www.osapublishing.org/oe/abstract.cfm?uri=oe-19-27-26666

My result in R=50micron is in the following figure:

The peak transmittance of my simulation is 52% and in article is neaar 63%.
The simulation file does not reach to min auto shutoff level.
I tested pml layer with 64 stretched but my result was not better than pml 32 layer.
My simulation file is below:
gold set r=50 um.fsp (294.9 KB)

can anyone help me to solve my problems?

Thank you so much,
Dezyani


#2

Hi,

The following things you can check:

  • Dielectric function matches to that what is reported by the authors. Also check the fittings in the materials parameters tab.
  • Did you perform a mesh refinement, wherein you have varied the mesh size. I noticed that your monitor was close to the structure. Does it need to be that close.
  • Finally check whether you have incorporated the boundary conditions properly.

Best Wishes,

Vivek


#3

Dear @vivek
Hi,
I simulated this article recently and have this problem about transmission. In article don’t say anything about the simulation parameter but in the other article from this group that is about this structure, author reported the gold and substrate parameter. the article is below:
http://pubs.acs.org/doi/abs/10.1021%2Fnl4041274[details=Summary]This text will be hidden[/details]

In my simulation I use a better mesh and mesh refinement but problem not solve. my simulation file is below:
article gold (gold change).fsp (295.8 KB)

1-You said: Did you perform a mesh refinement, wherein you have varied the mesh size. what do you mean?
2-You said: Finally check whether you have incorporated the boundary conditions properly. what do you mean? I use 32 and 64 layer stretched standard pml but the problem not solve.

Thank you

MEHRANI


#4

I quickly looked at the file and found one small issue, the source pulse has a small DC component (frequency=0Hz) that will never die off in the simulation no matter how long the simulation runs. One way to correct this is to turn off “optimize for short pulse” in the source’s Frequency/Wavelength tab (see the attached image for details).

I also suggest increasing the mesh size outside of the grooved region to speed up the simulation and trying out the conformal variant 1 option in the FDTD setup. See the mesh refinement page on the KB for details on choosing the conformal meshing technology setting.

There may be some other small issues with the files, but this should help get you closer.


#5

Dear @jpollock,
HI,
Sorry about answering late.
I did what you said about conformal variant and short impulse but my problem didn’t solve. my new simulation file is below:

gold set r=50 um not short impulse varient=1.fsp (293.2 KB)

and my new transmission is green line in below figure:

can you help me to solve this problems?

Thank you so much
Mehrabi