This simulation failed. Please contact Lumerical Technical Support


#1

Hello all,

I have a problem with my simulation. After 14%, the simulation stopped with this message : "This simulation failed. Please contact Lumerical Technical Support with
this error message: the reason for the failure was: basic_string::_S_create"
I am trying to calculate the resonant frequency of a microstrip patch.
Is there any solution to my problem ?

Thanks


#2

Hi @quantin.lienard,

Can you share your file (in layout mode) so we can have a look? Also, what version of FDTD Solutions are you using?


#3

Hello @gbaethge,

I wanted to share my file but it is too heavy for the website, I had to host it on Dropbox :

I am using the version 8.17.1157, windows 10 (64 bit)


#4

Hi @quantin.lienard,

Thanks for sharing the file. I had a look and there’s a couple of things that puzzle me:

  • You are using a uniform mesh with mesh override regions, it is contradictory, as you have different mesh sizes defined. Mesh override regions can be used with the non-uniform mesh as it allows to set a finer mesh over specific areas.
  • You set the simulation temperature to 77K. This will not affect the simulation unless you are using temperature dependent materials, as discussed here.
  • You modified the minimum mesh step to a very small value (2.5e-6um). This setting is there to prevent the use of a unrealistic mesh that could lead to a very demanding calculation resources.
  • The auto shutoff min was set to 1e-4 instead of 1e-5. This is to ensure the simulation runs enough so the fields decay enough by the time the simulation ends. If the simulation is too short (and the fields are still high), it can leads to some artefacts in the results.

That said, I’m not exactly sure what causes the error you had, but by using standard settings, the simulation ran without errors. I would suggest to start with the default settings and a coarse mesh and, once you are confident in the way the simulation is set, you can reduce the mesh size and eventually run a convergence test.


#5

Thank you for this detailed and quick answer !

The fact is that I have already successfully ran this simulation without the gold, so with the gold I just wanted to set finer mesh over gold area and set the auto shutoff to 1e-4 to limit calculation resources.

I will try with standard settings.
If I encounter any problem, I will post a new message here !

Thanks for the help