Simulating Electric Fields in Device (Electrostatics)

electrostatics
coplanarwaveguide
finiteelementmesh

#1

Hi,

I’m trying to simulate the electric field of a coplanar waveguide structure in Device using the Charge Transport solver, but I don’t have a good idea of how large to make the simulation domain, or how fine I need to make my mesh. If I make the simulation domain too large, I get the error message shown in the attached .pdf.

If I make the simulation domain small enough to avoid the attached error, I get what seems to be inconsistent E-field results. Example: when everything is grounded (including the Si substrate), I still have a fairly significant E-field between the Au regions. When the voltage moves up to 0.5 V and 1 V, the field appears to “jump” between very different solutions. This does not appear to be accurate.

I’ve attached my script for this simulation(the .lsf file), please let me know if there’s anything you think I can do to fix these results.

Thanks!
DC_Efield_CPW_SCRIPT.lsf (5.0 KB)

Device_Error.pdf (95.4 KB)


#2

The simulation setup that you have here looks okay to me. The reason you get a non-zero electric field in your monitors is because you have a metal-insulator-semiconductor type structure here. This type of interface is very common at the gate of a MOSFET or in a MOS capacitor. When the metal and the semiconductor gets connected to each other via the insulator, their Fermi levels align and based on the difference in their work-functions, there is a built-in potential drop in the insulator and at the surface of the semiconductor. This is why you get an electric field even at zero bias. (If you use a metal whose work-function is the same as the semiconductor then this built-in electric field will go away).

Since the electric field from the applied bias is adding to the built-in electric field, it looks like that the field is jumping suddenly. However the rise in the electric field is not noticeable at the beginning because it gets masked by the pre-existing electric field. On top of that, if you are looking at the peak value of the electric field, you will notice that the peak value is at the corner of the metal objects due to the sharp corner there. If you want to see how the electric field between the metal regions vary with bias it might be a better idea to look away from these corners. In the attache file (DC_Efield_CPW_Sim_MOD.ldev (6.2 MB)), I have added a 1D monitor to capture the electric field in the region between the metals contacts. I have also made the work-function of the metal to be equal to that of the silicon. If you run the simulation and look at the electric field along the line monitor, you will notice that the magnitude does vary fairly linearly.

A few suggestions to improve the mesh in your simulation,

  1. You will notice that I have made the grounding contacts thicker. This thickness will not affect the behavior of the dece but the extra thickness will allow the solver to use a coarser mesh near these contacts (otherwise the mesh would be very fine there due to the thin metal layer). I have also extended the “Air” and oxide layers to fill the extended simulation region along x axis.

  2. In order to make the mesh more uniform, I have next made the default mesh settings (in the “Mesh” tab of the solver region) very large and have used a mesh override region to refine the mesh size everywhere. This was done because if we use the default mesh settings, by default the CHARGE solver uses a finer mesh in the semiconductor than in the metal or insulator. By using the mesh override object instead we can make the mesh size uniform everywhere.

  3. I have made the “max edge length” in the mesh override objects in the gaps larger than your original settings. You will notice that the solver is still giving a warning saying the mesh is not refined properly. You can solve this warning by following the tips in this post: How to resolve error message: “The mesh is valid but may not be adequately refined” .

  4. I have made the metal work-function equal to that of silicon but you should change it back to the default value to get accurate results.