S-Parameters from 2017 new feature and Interconnect


#1

Hello,
I would like to ask if it is necessary to install INTERCONNECT 2017 in order to use the .dat files created by S-parameters matrix sweep of FDTD 2017. Because I do not take results using the previous version of INTERCONNECT even if the .dat file is loaded in Optical N-port S-Parameter.


#2

Hi @evachat,

This should not be the case since the s-parameter file format has not been changed. Please make sure your .dat file is in the correct format as shown in the following page:

https://kb.lumerical.com/en/index.html?ref_primitive_elements_optical_n_port_s_parameter.html

And please attach your simulation files if it is okay so that we can have a look to figure out the problem. :slight_smile:


#3

Hi,

I attach the .dat file taper.dat (13.7 KB) created by FDTD as well as the Interconnect simulation file where i want to check the results taper.icp (120.8 KB).

What I noticed is that when I change the labels, mode ID (out), mode ID (in), to the number 1 then I can take results but I cannot logically explain it. Can you clarify what these labels are?


#4

Hi @evachat,

Your observation is correct. The ‘mode ID’ (out & in) is a crucial parameter in defining s-parameters. It defines the mode number (e.g., TE0 as 1, TM0 as 2…). Thus for one of the headers in your .dat file

("port 2","mode 7",7,"port 1",2,"transmission")

It represents the inter-mode transmission from mode 2 to mode 7 from ‘port 1’ to ‘port 2’ (coupling coefficient from mode 2 to mode 7 from port 1 to port 2). If you are measuring the intra-mode transmission, the mode ID for both input and output ports should be the same.

Another crucial parameter is the ‘orthogonal identifier’ setting in the ONA. It represents the excited mode for the ONA output. So for the header mentioned above, the excited mode from the ONA should be 2 to be able to have results shown for mode 7.

I hope this could help. Let me know if you find any difficulties in reading this :slight_smile:


#5

Ok, thanks. So I have to set also the orthogonal identifier according to the header. In this case, can I use the S-Parameters module, in bidirectional mode? Input signal->[port1->port2]->[port2->port1]?


#6

Hi @evachat,

Theoretically you don’t need to match the ONA’s orthogonal identifier to the header of the s-parameter, it is just in this case, you may not have any output measured (since the transmission is not defined in the s-parameter file).

You can definitely make the s-parameter bidirectionally, and you can make it multi-mode as well. To do this, you just need to adhere all the s-parameters together in the file:

("port 2", "TE", 1, "port 1", 1, "transmission")
...
("port 1", "TE", 1, "port 2", 1, "transmission")
...
("port 2", "TM", 2, "port 1", 1, "transmission")
...
("port 1", "TM", 2, "port 2", 1, "transmission")
...
...

I hope this could help :slight_smile: