Running FDTD simulation from script causes error once read data from monitor

Dear all,
I face error which might have simple solution.

I have a scriptTempreture depandance resonance.lsf (898 Bytes)
and model MR.fsp (2.3 MB))

What I want is to tune the temperature and check the resonance shift. So I found a https://ntrs.nasa.gov/archive/nasa/casi.ntrs.nasa.gov/20070021411.pdf how to implement Silicon refractive index dependence with wavelength and temperature via Sellmeier equation.

I created Sellmeier material in FDTD and script calculates its coefficients for current temperature and update the material each for-loop iteration.

I run script and for my PC it takes 4 hours to simulate one iteration, but once iteration almost finished (1 minute left) I got error:

Warning: C:/Users/m.ryabko/Desktop/Heat simulation/Tempreture depandance resonance.lsf line 24: in run: there was no simulation data. The simulation failed to run.
Error: C:/Users/m.ryabko/Desktop/Heat simulation/Tempreture depandance resonance.lsf line 25: Can not find result ‘T’ in the result provider ‘monitor_out’

and simulation never stops (first I got issue during New Year holidays, so it was on hold for 9 days! second time today with about 10 hours on hold).

However, when I relax mesh accuracy to decrease the time for each iteration (about 2 hours) everything works fine!
So I can suspect once the simulation finished there is no data yet available in monitor object, so the script asserts an error.

  1. Is there more correct way to run simulation from script and read data. Maybe there is script command to delay once data ready?

  2. Is there more appropriate way to simulate temperature dependent material’s refractive index

  3. I noticed strange issue with material explorer particular for Sellmeier material.
    Once I try to fit and plot the refractive index for some wavelength range it provides always constant value:

However if check values for specific wavelengths the values are different as they should be!

So is my implementation of Sellmeier material is incorrect or there is issue with Lumerical FDTD for this particular material visualization?

Hi @m.ryabko,

Thank you for your question.

  1. If the simulation runs fine at a lower mesh accuracy, I suspect that this may be a memory issue. You should check the Simulation and Memory Report to make sure you have enough memory to run the simulation:
    image
    The data collection phase of your simulation will require more than 50 GB of memory to run:
    image
    In particular, your field monitor that covers the x-y span of the simulation will require 25 GB:
    image
    I suspect that this is what is causing your problem. If I disable this monitor the memory requirements are much lower:
    image
    Try disabling that monitor and running again. You could also reduce the number of frequency points recorded by your monitors to reduce the memory requirements.

  2. In FDTD Solutions there are built-in linear and nonlinear temperature perturbation material models that you could use. Your method should work fine as well. Which method you choose just depends on which model you believe is better suited for your simulation.

  3. The Sellmeier model is an analytic model so no fitting is necessary. Material fitting is only needed for fitting to sampled material data.

I hope that helps. Let me know if you have any questions.

Best Regards,
Kyle

Thank for your comment.

Well, I found the issue with memory, you are right. So I disabled all the monitors but monitor_out.
No I need about 1Gb memory. I run simulation through UI one by one, and it is fine.
But when I run it from script I faced same issue. So I still with the same error.

Update:
Moreover, I’ve reduced the mesh accuracy to 2 to speedup simulation and relax memory requirements. However simulation successfully run through 3 iterations, and got same error after 4th iteration.

It is strange that you can run your simulations through the GUI but not from the script.The material parameters are the only thing you are changing between the simulations, correct? Have you tried running your script while keeping the material parameters constant between the iterations?

Can you send me the new simulation file and script you are using? Also, which version of FDTD Solutions are you using?

Thanks for your support.
This is screenshot, demonstrating failure on 4th step. Version 2020a.


Model MR.fsp (1.5 MB)
and scriptTempreture depandance resonance.lsf (914 Bytes)

And I have not tried to not change material properties because tuning refractive index is the main purpose of this simulation.

Update:
Today I rerun script without any modification in files, but simulation terminates after 3 iterations (yesterday after 4th). Looks like some unknown factors affects the simulation.

The script you sent runs fine on my computer. Could you send a screenshot of your resource configuration (click the “Resources” button on the main toolbar)? And the simulation log files as well? Thanks.