Run test error: FDTD Version mismatch



I installed FDTD Solution 8.20.1634 on a Xeon Phi machine 7210 running on CentOS 7.3.1611.
The application is installed and fetch the floating license on another computer without trouble. The FlexNet license manager is on its latest version, 1.7.1073, and running on a Windows server machine.

Problems arise in the “Resource Configuration” tab.

I can run simulations using the “Local Computer” job launching preset, it passes the the configuration test, but it is very slow (slower than a desktop computer).
Therefore, I tried using MPI, both MPICH2 Nemesis and Intel MPI. In both cases I get errors.

a) For a low process counts I get the error message “FDTD Version mismatch”

b) For a high number of process I get a timeout.

I checked that the MPI was properly recognized by FDTD Solution and get the same result with the default and Intel MPI. Here is the MPI configuration, as returned by “”:

I am not sure of where the “FDTD version mismatch” is coming from: I am using a single machine (with a high number of processors), with only one version of FDTD, so no conflicts between nodes or something.

If anyone has ideas regarding this error message it would be greatly appreciated.

Have a nice day,



Did you install FDTD Solutions and FlexNet license manager as shown from our KB installation guide?

If so, MPICH2 should be installed using the default location.

  1. Try to run an example simulation:
    – save these files into your local user account folder. ie… "~/" or "/home/your_username/"

  2. Set your resource configuration to:

    job launching preset = remote: MPICH2
    #processes = 8, #threads = 1

  3. Otherwise, use “Custom” as your job launching preset and please make sure that the command to execute on the advanced resources points to the correct MPICH2 location for your version of FDTD.

Hope this helps.


Dear Lito, thank you very much for your swift answer.

About the installation process, yes I followed the KB installation guide.
The FlexNet license v1.7.1073 is installed on another computer of the network, running on Windows server 2012, and used daily by our regular FDTD cluster and desktop computers.
For FDTD Solutions on Linux I followed the guide and installed FDTD Solutions v8.20.1634.

The licensing seems to be properly configured, there is no error when starting the software, it can fetch properly the license.

I confirm that MPICH2 is installed in the default location. “mpiexec” is in this location:

Here is the output when I run the configuration test:

I can, however, run the simulation.
The simulation is really slow, 2.7 MNodes/s, compared to my simple desktop, 128.7 MNodes/s.
Here is the log file:
ppc_cavity_p0_xeon_phi_MPICH2.log (9.9 KB)

I tested another MPI, the Intel MPI and got the same output:

In this case the simulation is faster but still underperforming.
Here is the log file:
ppc_cavity_p0_xeon_phi_IMPI.log (9.8 KB)

For the sake of comparison, here are the performance of both my desktop and the Xeon Phi machine using the LINPACK benchmark.

I understand well that the number of GFlops do not transfer directly into FDTD power but it seems reasonnable to expect the new machine to perform FDTD computations faster.

What does “FDTD version mismatch” exactly means?

I tried to look for it but couldn’t find anything. Now this post is the top answer on Google for this result.


I will forward this to our development team to look into any configuration or settings on a Xeon Phi 7210 system. We will get back to you as soon as possible.

As for the FDTD verison mismatch. The error will sometimes occur when #process is set to more than 1.
To just run the test, please set the #processes to 1 as shown. Then every time you RUN the test it should not anymore give you the FDTD version mismatch.We are also looking into this issue on Linux systems and will try to have this fixed on our upcoming release.

Thanks for the updates.


Please find attached the result you asked for:

I also ran other combinations I could think of, all returning the same error.

Before doing these tests on CentOS I did some previous tests on Windows. However, on this operating system the system struggled to achieve good performance both on the LINPACK benchmark and in FDTD Solutions. This could have been a configuration problem on my part though.

Thank you for your help,


Do you get the version mismatch error everytime you run the test after changing the resources to processes 1 and threads 1 and then saving the settings. Open the resource configuration after and re run the test.

Please save the resource configuration first after doing any changes. Then open again and run the test using the saved settings.

We are looking into this issue with the Run Test option. From our tests, it sometimes give a false error of version mismatch but will also provide a “successful test”.

If the simulation if able to run even with the mismatch error - this should not affect your simulation. For the moment we can ignore this error and will try to have this fixed in the next release.

As what we know, Xeon Phi performs better on Linux systems and we are not sure if Xeon Phi comes pre-installed with windows system.

Another test we can do is use the example file from this KB page:
This should provide some comparison with other systems that we tested.

This guide from Intel might be useful.

Configuration Options
After installing the software stack, you can configure the Cluster and Memory Modes on your system. Please refer to the following article for information related to configuring Cluster and Memory modes supported by the Intel Xeon Phi processor.
Intel® Xeon Phi™ x200 Processor - Memory Modes and Cluster Modes: Configuration and Use Cases



It seems odd that after I rebooted my machine I am not able to reproduce the “FDTD mismatch error”.
Please try to reboot the Linux machine. Not sure if this will resolve the issue with a false error. At the moment, 3 Linux machines running different versions of CentOS and RHEL cannot reproduce the issue.



Yeah, I get it even after rebooting.

It may be a configuration problem on my part.
I am currently using CentOS 7.3.1611 as it is in the list of the validated host operating systems for the Xeon Phi, also using the recommended Kernel (kernel-

I will try to reinstall everything again, this time using the latest version of CentOS, or maybe a trial for RHEL.

Could you share the level of performance of your Xeon Phi machines on the file benchmark.fsp? Machines using this processor are not on the “FDTD Simulation benchmark” webpage. It would help getting an idea of what performance to expect, what is normal, etc.

Again, thank you very much,



Thanks for the updates. Our development team looking into this issue and will try to have a fix soon.
For the moment, we can confirm by running a sample simulation job like the nanowire.fsp. No need to reinstall your operating system.

As to the Xeon Phi setup we have the following:

  1. Use Intel MPI to run simulations
  2. Xeon Phi configured in cache mode
  3. Optimal -n -t configuration varies by simulations. Please refer to this KX post for more details:
    How to obtain the optimum FDTD resource configuration?

Performance wise, does your system have better results that those we have tested? Whats the resulting mnode/s for the benchmark.fsp? Is it faster that the Intel® Xeon® Platinum 8175?




Please try to upgrade to the latest release of FDTD Solutions 2018b R2 (v8.20.1661) for Linux.
Let us know if the “Mismatch false positive” error when running the test, is still an issue.



Dear Lito,

I apologize for late answer.

I upgraded to the release 2018b (v8.20.1661) and I still get the error “FDTD Version mismatch”.

I am using Intel MPI, and the Xeon Phi is configured in cache mode.

I tried running benchmark.fsp, please find attached the log:
benchmark_p0.log (10.4 KB)

It runs at 16 Mnodes/s for 16 processes…


Please try to Run the Test using our MPICH2 not Intel MPI. Please ignore the run test error if you want to run using Intel MPI.

The simulation result is too slow for your current system. Regular desktop computers normally runs ~ 100 Mnodes/S. Can you please try to run the simulation using the same # processes using “Local Computer” as the job launching preset?

Changing the # of threads as desired. ie… # threads = 16

Or try to use “Remote: MPICH2” as the job launching preset instead of Intel MPI? Using; # processes = 16

Please let send us the resulting Mnodes/S for the above resource configs.