Problems with items of SiEPIC PDK


#1

Hi
I downloaded the SiEPIC_EBeam_PDK and i installed it in INTERCONNECT. Every time i drag and drop the “ebeam_ring_singlebus_te1550” this message is presented below.


This happens for all the the objects of this library.For example the following image.

What is going wrong ?
Also , i doubt for the results. This error may affect the results ?
Could i ignore this message?


#2

Hi @konslekk,

These errors are all related to the Monte-Carlo properties. You got the “error evaluating expression” errors because the MC related properties are set based on the expressions (like shown in the figure below)

and these expressions will be initiated when you run the “INTERCONNECT Monte Carlo Simulation” from KLayout. Please refer to the post Klayout-INTERCONNECT Ring resonator simulation for detailed information about KLayout-INTERCONNECT integration.

These errors won’t affect the usages of the EBeam compact models in INTERCONNECT. However if you want to evaluate the KLayout-INTERCONNECT integration, an extra license is required. Please contact support@lumerical.com or sales@lumerical.com for more information and for evaluations.

I hope this could help :slight_smile:


#3

Hi @gwang
Something is going wrong with INTERCONNECT. There are some malfunctions and difficulties. When i try to drag and drop an item form “SiEPIC_EBeam_PDK” then INTERCONNECT does not work properly and are presented some malfunctions with the mouse of my computer every time i do this procedure.After many efforts and one restart of my computer i ignore this errors and continue.

I want to simulate a single bus ring resonator from SiEPIC_EBeam_PDK.
Properties :
width=0.5[μm]
height=0.22[μm]
gap=0.1[μm]
radius=5[μm]

The S parameters for this ring resonator exist, so FDTD does not need to be lunched automatically.


Now i want to change the radius. New radius=4.5[μm] then FDTD will be lunched automatically to calculate the new S parameters.

I can notice that with radius=4.5 the center resonant wavelength has been shifted.
Now i change again the radius. New radius=4[μm].

I can notice that the center resonant wavelength is approximately 1.565[μm].
Finally, i change one more time the radius. New radius=3[μm]

As you can see the the center resonant wavelength has been shifted for one more time.
The center resonant wavelength should remain the same for various radius. I don’t know what is going wrong.
I tried to simulate the whole single bus ring resonator with the same properties in FDTD solutions for various radius.


That was the result:

As you can see the center resonant wavelength remains the same and it is approximately 1.55[μm].
I don’t know what is going wrong with INTERCONNECT.
Please help me !


#4

Hi @konslekk,
Theoretically speaking, why should the center resonant wavelength remain the same as you change the radius?
If 2pi5 neff = N * 1.55, does the radius of 4 um satisfy 2pi4neff = (N-2)*1.55?


#5

Hi @konslekk,

Seems like there is some problem with this element and adding it to the schematic editor performs strangely on my computer as well. We are working on it now and will update this element shortly. I will definitely keep you in the loop about the progress. Thank you for bring this up.

I am not able to test the performance of this element given the adding problem. I think the result of your FDT simulation is correct that the resonance peaks align at the center wavelength and the FSRs change. Once we have the problem fixed, I will follow up with you on this part.


#6

Hi @aya_zaki
For a specific neff the center resonant wavelength remains the same. A ring resonator is like a microwave dielectric cavity with an inner and an outer radius and 1.55[μm] is the wavelength that we want to function this cavity. A cavity supports many resonances. We care only for a certain number of resonances. Let’s assume that center resonant wavelength is the 10th resonance. If we change the radius the center resonant wavelength will be shifted to another resonance, maybe will be shifted to 8th resonance, but it still remains to 1.55[μm]. All the other wavelength resonances will be changed.


#7

Thanks for your reply. But I think this can only happen under the condition that the ring circumference is very large compared to the wavelength so that the N is very large. (Here it is around 80, right?)


#8

Hi @konslekk,

Update for the single bus ring element: I got back from Lukas’ group and indeed there is a problem on this element. They suggest to use the “ebeam_dc_halfring_straight_te1550” element to build the ring structure. Please note that this will end up with double bus rings rather than single bus rings. If you really want to use a single bus ring structure, you could build your own model based on your FDTD simulation.

I hope this could help. Let me know if you need any help on building the models.


#9

Hi @gwang
I read your post in https://github.com/lukasc-ubc/SiEPIC_EBeam_PDK/issues/128
In your post you wrote that the problem is with “ebeam_ring_singlebus_te1550”.
The problem is not only with “ebeam_ring_singlebus_te1550” but also with “ebeam_dc_halfring_straight_te1550” . When i drug and drop the “ebeam_dc_halfring_straight_te1550” the schematic editor runs into an endless loop of asking for s-parameters and adding other copies of this same element in INTERCONNECT . The same problem appears either with “ebeam_ring_singlebus_te1550” or with “ebeam_dc_halfring_straight_te1550”. I think there is a serious problem with the element “ebeam_dc_halfring_straight_te1550” . Could you please check it out ?
Could you please upload this problem in GitHub?

Also, i would like to inform you that, is not my purpose to build double bus ring resoantors, it is out of my thesis. In my diploma thesis i want to build optical phase filters with single-bus ring resonators.

Best Regards
Konstantinos.


#10

Hi @gwang
I have tried many times to simulate the single-bus ring resonator in FDTD Solutions. In the last edx courses with Lukas , i asked him if i can simulate the single-bus ring resonator in FDTD Solutions. He answered to me that it is not a good method to simulate the whole ring. The best way is to simulate first the directional coupler “ebeam_dc_halfring_straight_te1550” and then go to INTERCONNECT and add the other half waveguide . It is very important to fix the problem about the “ebeam_dc_halfring_straight_te1550”. Please help me.

Best Regards
Konstantinos


#11

Hi @konslekk,

I don’t really see the same problem in the element “ebeam_dc_halfring_straight_te1550”. Could you please double check for this? If you really see the same problem, there might be some issues other than the element itself. Let’s confirm this part first before we go further on the discussion.


#12

Hi @gwang
I would like to excuse myself . I will agree with you .This is not the same problem in the element “ebeam_dc_halfring_straight_te1550”. But something else is going wrong with the element “ebeam_dc_halfring_straight_te1550” .
I separated the single bus ring resonator in two elements.
First element : "ebeam_dc_halfring_straight_te1550_1"
Second element : “ebeam_wg_integral_1550_1”

Properties of the first element :
wg_width = 0.5[μm]
wg_thickness=0.22[μm]
radius=3[μm]
gap=0.1[μm]

Properties of the second element:
wg_length= half of the radius of the first element
wg_width=0.5[μm]

I made a simulation with three different radius. (Radius=3[μm] ,Radius=5[μm] and Radius=4[μm]). For Radius=4[μm] FDTD Solutions was be launched automatically to calculate the new S parameters.

Lets see the transmission spectrum for the three different radius.

I was expecting to have a center wavelength that will remain the same for the changes of the radius. Why the center resonant wavelength does not remain the same ?


#13

Hi @konslekk,

Is there a particular reason that you want to set the straight waveguide’s length to half of the ring radius? To make a practical ring, you need to set it to pi*radius, which is half of the ring circumference.

I did a rough test and the ring’s gain curves kind of aligned at ~1.52 microns and ~1.615 microns and the FSRs followed the right pattern. Note that we are using a piece of straight waveguide instead of half ring, so the curves are a bit off. Another setting that may help to get a better result is the plotting resolution (“number of points” of ONA); increasing this number may give you a more accurate plot.

I hope this could help. I’d love to discuss more if you have further questions :slight_smile:


#14

Hi @gwang
Excuse me . It was my fault . It was a misprint. I mean that the straight waveguide’s length is half of the ring circumference.
wg_length = pi*radius


#15

Hi @konslekk,

No worries. I think the best way to do this is to build your own compact model based on the FDTD simulation since you already have it. Then you will have accurate simulation results. The CML & PDK chapter will be rolled out very soon on KX, and all the model building details will be there which you can take advantage of. Meanwhile, let me know if you need any help to get started.


#16

Hi @gwang
Properties of the “ebeam_dc_halfring_straight_te1550” element :
wg_width = 0.5[μm]
wg_thickness=0.22[μm]
radius=5[μm]
gap=0.1[μm]

Properties of the “ebeam_wg_integral_1550” element:
wg_length= half of the circumference of the first element
wg_width=0.5[μm]

As, you already know , there is a ".dat " file with the S parameters of the above “ebeam_dc_halfring_straight_te1550” element. So the FDTD Solutions is not required to be launched automatically because the “.dat” file with the S parameters already exists.
This is the transmission spectrum.

**I would recommend you to make a test . You will discover something very strange.**Open the “ebeam_v1.2” folder —>“source_data” folder—>“ebeam_dc_halfring_straight_te1550” folder.
Find the “.dat” file of radius=5[μm] and delete it .

Then, go to INTERCONNECT and try to drag and drop “ebeam_dc_halfring_straight_te1550” element. A message will be appeared. The S parameters does not exist , so FDTD Solutions will be launched automatically. After FDTD simulation is complete , you can plot the transmission spectrum.

You would expect that the new transmission spectrum will be the same as previous. But, it’s not the same. Here is the new transmission spectrum.

Here is a image with the two diagrams in one, so you can look it better.

I had the expectation that they will be the same.

Best regards
Konstantinos !


#17

Hi @konslekk,

I do see the same effect as you described. However I haven’t got the chance to look into details in this question yet. There are several possible reasons, all based on the fact that the original file is simulated by an old version of FDTD:

  1. The default mesh setting in the new version of FDTD has been changed
  2. The material index in the new version of FDTD has been changed

and there are other possibilities as well. I will look into it and let you know as soon as possible.


#18

Hi @konslekk,

I am not so sure what causes this effect, I will keep digging into it. The most possible reason I can think of is that, the original results may be generated under a different mesh setting. What I recommend to do now is to re-generate all the files you need using a same mesh setting that you want, and then use them for further simulations.

I hope this could help to some extent :slight_smile:


#19

I suspect that different mesh settings were used for the file provided. I agree with @gwang – run the simulations with the parameters that you trust, e.g., mesh=4.


#20

I suggest that you check the simulation time is long enough in the related FDTD files.