Problem with running varFDTD


I have a problem with running varFDTD that extends beyond running my simulations that I have created myself. I try running var FDTD with Lumerical example files such as ring_resonator.lms and waveguide_coupler.lms and they won’t work as well. Here is what happens.

In most of the cases, after activating varFDTD solver and running it, the progress window shows up pretending that the structure meshing is being performed, and then running is being executed, but no progress is being shown. The window disappears after a few seconds - just like if the simulations were completed, but there is no simulation results: all the monitors show blank results window. Did anyone experience this issue? Is there something that I may be missing to run the simulation?

FDE mode solver works fine with both my files and Lumerical examples.


Hi @Ksenia.Dolgaleva

This is strange. Are you running the files as downloaded?

  1. What version of the software do you use?
  2. Can you try running them in a different machine?


Thank you, Behzad.

Indeed, running my lms file on a different machine worked without any problem, but the machine I’ve been running it on is my friend’s.

I am presently on Mac OS X 10.9.5 High Sierra, running the latest version of Lumerical 7.11.1541 (just downloaded it last week from their website) - this is the arrangement that doesn’t work for Lumerical MODE, var FDTD and EME solvers (FDE works fine).


Hi @Ksenia.Dolgaleva

I ran the two simulations that you mentioned in a Mac OS 10.13.3 High Sierra, and it finished simulations successfully. I could visualize the results too.

I think the first step is to check and see if it is the visualizer problem or not. Once you ran the simulations, could you see a red box around the monitors as is shown in the screenshot below, or any results in the Result View window?

I do not remember this problem with previous Mac OS versions, but it might worth to upgrade the Mac OS to recent versions.


Hi Behzad

I am using latest version of Lumerical Mode 7.12.1634 on windows 10 and facing the same issue. Lumerical varFDTD does not work. When you click run progress window opens up and disappears after few seconds. No simulation is performed as there is no data in monitors after the progress window closes.

Mode Solutions is working fine.


Hi @mchaudhery13

You are using an older version of our products. Please upgrade your software and let me know if you still had any problem.

Also, check your Resources settings and make sure that you are not over-subscribing i.e. the number of assigned processes or threads is less than what is specified in the CPU specs. For example, I am using 10 out of 12 available threads:

Hope this helps.

Solver is not working in MODE

I am getting the same error. Either the FDE is enabled or varFDTD and when I run there is nothing showing in the result view for the monitors


Possibly problem is very similar to this:
EME solver not running

Can you try using MPICH2:

Please keep me updated with your results.