problem in saving results from visualizer in FDTD and DEVICE

visualizer

#1

Hi

I am trying to save results from visualizer in image format, but I keep receiving an error as the attached file.
can you tell me what is the problem please? or the best ways of saving lemrical results.

Thanks


#2

Hi @heejae86,

Could you tell us more information about how you saved (or failed to save) the figure? Have you tried the “Export to…” option from the side bar? Please try it first and let us know whether it works or not.

It seems like you are using an old version of the software since we updated the “Export to JPG” icon to the following, so update to the latest version may help to solve this problem.

I hope this could help :slight_smile:


#3

Hi

I am using version 2016 for mac. it has “export to JPG” tab but it gives error. only exporting to txt works. so I have to export to txt file.

is there any script command to export to JPG or JPEG?


#4

Hi

Can you please tell me which version of MATLAB is compatible with lumerical 2016 for mac?


#5

I receive this warning when I try to exprot as jpg or jpeg

1: in exportfigure, there was an error exporting the figure, the file was not successfully created.


#6

Hi @heejae86,

You are right that “exportfigure” is the command to use. I just tested FDTD 2016b on MAC and it worked fine for me. Exactly which version of the software are you using?

For the MATLAB integration, we support MATLAB version 2006b (7.3) and newer. Please make sure you successfully configure the integration before you use it. Please refer to Matlab Integration and API setup for the configuration process.

Another thing to check, do you have the permission to write to the destination directory? Since you can export text file, I guess this should not be the problem.

I hope this could help to some extent.