Photothermal heating in all dielectric metamaterials


#1

Hello,

I’m trying to simulate the effect of photothermal heating in all dielectric metamaterials. I’m following the tutorial “Photothermal Heating in Plasmonic Nanostructures” (https://kb.lumerical.com/en/index.html?sp_photothermal-heating-in-plasmo.html); hence I first calculated the optical properties of the metamaterial with FDTD (model: Squares array_Ge.fsp (312.6 KB))
Then, I imported the optical absorption data saved by FDTD Solutions to device (model: https://www.dropbox.com/s/phy5fmi3n08pfw3/Ge_MM_array.ldev?dl=0)
However, I have a message of error saying “error code 9002” when I try to run the simulation.
Could you please help me with this problem?

Best,
Davide


#2

Dear @dp5c14

Thank you for attaching simulation files and sorry for late reply. We had a long weekend here.

I think your simulation file is set properly. The problem is that you are using a locked mesh, which uses mesh settings of dipole example in the link below:

https://kb.lumerical.com/en/sp_photothermal-heating-in-plasmo.html

Error code 9002 is very general. You can find a few posts on KX that discusses how to fix this problem.

My troubleshooting steps were to fist disable heat source to see if the problem is arising from geometry/mesh building. Once I saw it is running successfully with disabled heat source, I enabled heat source and checked HEAT solver to modify max update, as is explained in this link: Heat Flow solver failed to converge after 40 iterations, error code 9002 (which you already have set it to 1000k). Simulation was still diverging.

Thanks to @aalam, we noticed that job manager shows that mesh is being loaded:

and visulazing HEAT Solver boundaries shows some boundaries with material that does not exist in this simulation, and also a zero heat power flow from +z boundary:

This indicates that mesh is locked in this simulation:

Thus, I disabled the Mesh Lock option and added proper air-Ge (Germanium) and Air- SiO2 (Glass) -Sze BCs from Material Interface. I set the scaling factor to 1 for Heat Source so that simulation is faster. Here is the result that I get:

I hope this explanation was clear and results make sense.
Please let me know if you had further questions.

Thanks


#3

Thank you very much for the help!

Davide


#4

I’m sorry but I have another question: how did you set proper air-Ge (Germanium) and Air- SiO2 (Glass) -Sze BCs using Material Interface?
I tried to do this, but I don’t quite understand how material interface works.

Thank you!

Davide


#5

Dear @dp5c14

From Material Interfaces window, select Air and then add material (Ge and SiO2) to Interfaces box. Then, select Convection from Thermal tab to set the value for h (W/m2.k). Here is an screenshot for your review:

I hope this answers your question.
Thanks


#6

Thank you very much!

Davide