Nested sweep errors - results could not be concatenated

Hi

I’ve tried to run a nested parameter sweep. (Reflection vs. incident light angle & Wavelength). However, after running a sweep I encountered with this error! Could you please let me know how I can fix it? It must be noted that when I omit the wavelength dependency, there would be no problem, and I can plot reflection vs. incident light angle.

Hi @msh150

This seems to be a bug in previous versions (It looks like software was getting confused when you were sweeping over the source wavelengths), but it has been fixed in the latest releases.

Please upgrade your software to the latest version using the link below, and upload the simulation file for a review if you still had any problem.

https://www.lumerical.com/downloads/customer.html

Thanks

1 Like

taper_edgeAngle_sweep_problem.fsp (348.2 KB)

Hi I am having the same problem. I have uploaded the model. Could you please have a look.

Thanks

Hi @ayan.chakrabarty,

Welcome to the community!

I checked your file, the problem stems from the results being derived for different x coordinates at each simulation. You can fix this by enabling the override x mesh option (shown below).

mesh_order

Kind regards

Hello,

I am trying to simulate a taper waveguide. A sweep is set up over the facet angle which changes the structure in each step. Individual simulation runs fine. However if you run the sweep it throws an error : “individual results could not be concatenated”.

Any idea where things might be going wrong?

Thanks

@ayan.chakrabarty I merged your post into this question you asked earlier; please find the answer above.

Kind regards

Hi,

Thanks a lot. That means whenever we have sweep set up that changes the structure in each step, the automatic mesh set up (auto non-uniform) will not work and we have to override the mesh with the mesh setup function/icon ? Since, in the mesh setup function you have to define geometry, do we need to do it over the entire simulation region?

For running a sweep, there are two main requirements for the results to be merged:

  • Matrices having same dimensions.
  • The data being recorded for same coordinates (x, y, z).

Following a change in the structure, the mesh would also change when using the automatic mesh setup.

Therefore yes, you need to enable the override mesh option when sweeping to ensure that results are obtained for same coordinates.

Answering your second question, since the cells need to match across the structure, the mesh will extend out from the defined mesh object (in directions which you have enabled the mesh override for). Therefore, in your case given the geometry, you can expand your mesh object in Z direction so it will fully apply to your monitors (shown below).

mesh_geometry

Thanks a lot.

What will be the difference if I use the option “set equivalent index” in the general tab instead of using " set maximum mesh step". I have found huge difference in the simulation time depending on what you chose. May be I am doing something wrong?
How do you chose the equivalent index in the x, y,z direction when you have say two different materials one inside the other, say for the model that I uploaded.

Many thanks for your help

Hi @ayan.chakrabarty,

Sorry for the delayed response. Regarding using the equivalent index option, I quote from this post which presents detailed instructions for using and setting up the override mesh object in FDTD:

"In most cases, FDTD uses the number of points per wavelength for meshing. The larger the refractive index of a geometry, the smaller (finer) the mesh size. So, the equivalent index will depend on how small you want your mesh to be in the override region.”

Therefore, in this method the mesh accuracy is no longer static and changes as the mesh accuracy slider is altered, which could be advantageous for convergence testing.

Changes in simulation time is expected as the trade-off for having a finer mesh is an increase in computational requirements. That’s why performing convergence tests is an effective approach to determine the ideal mesh settings (as opposed to simply using the finest mesh possible).

Kind regards

1 Like

Thanks much !!

1 Like