Mode Expansion Monitor error: "Failed to calculate results!"


#1

I used the mode expansion monitor to expand a mode for a few transmission monitors in 3D FDTD simulation.

However, after the simulation finishes, and I try to view the results, there is a pop-up message saying “Failure to calculate results!”

The transmission monitor is the same size and covering the same area as the mode expansion monitor, so I am not sure what the problem is. The monitors are set to be broadband over a wavelength range.

Thanks!


#2

Hi, could you share your simulation file with us so we can have a look at the detailed settings and try to reproduce the problem?


#3

I have the exact same problem as stated above.

Before adding the mode expansion monitor and required code everything worked fine.
Now it keeps complaining it can’t do the expansion (and therefor not execute the analysis script).

I do have to mention that I do not use a modesource, however if I can only do it with a modesource then the whole expansion monitor is kind of pointless. I’m using a dipole source (taking Purcell factors into account).

I can provide the file but I do not want everyone to have access to it at this moment.
Lumerical engineers or people form the lumerical support team is fine though.


#4

Inside the Exp. monitor settings, have you define the modes into which the power should be expanded? And the field monitors too?
I think the excitation source type should not be a problem.


#5

Yes I have set 1 monitor to be expanded for now.
When I right click and choose calculate for that monitor then it gives me the same error as the OP.


#6

Well, it is hard to guess without the file. I hope you can eliminate any specific details related your novel design and just upload a simple file with the problem. Of course, you are welcome to send it to me in a private message too.

R,
Aya


#7

I’ve send the file in a private message.

I will send it to people willing to help me, since that way I have enough control.
Thanks again for trying to help me.


#8

I’ve resolved the issue, the amount of frequency points, between the expansion monitor and the dft monitor weren’t the same.

Maybe that’s the same problem as the OP had, if you run into this issue check the frequency points and settings, for all monitors involved, the expansion monitor and the source.