Mode calculations for a waveguide coupler with FDTD Solutions


#1

Dear users,

I have a problem with mode calculation with FDTD Solutions. By using a mode source in FDTD Solutions and 2D FDE Solver in Mode Solutions for the same structure, I obtain different results. The structure is a directional waveguide coupler .

I think the problem lies with mode source since the modes (with the exception the fundamental ) expand to the borders of the structure when they are supposed to be confined in the waveguide :

With the EigenSolver, I obtain the following :

I have also noticed that there is no such difference if the waveguides have a deeper ridge / the modes are well-confined.
If anyone has an idea about this problem, I’d be glad to hear from them.


#2

Hi @flore.h
As you already said the first figure, the modes expand to the border of the structure. I can see that the field is very high at the edge of the coupler since it is red. Could you please tell about the boundary conditions that you have installed in the FDTD simulation file ?


#3

Hi,

In the FDTD simulation file the boundary conditions are all PML, with the following parameters :


#4

The mesh is also uniform with a 4 nm step.


#5

Hi @flore.h
Sorry for the delay. Could you please upload the two files, one from FDTD and the other MODE solutions to check them further ?


#7

Here is a link to the FDTD file:
WG2_shallow_ridge_wSi=450nm_dRib=25nm_S=650nm.fsp (248.4 KB)
and to the Mode Solutions file:
WG2_shallow_ridge_wSi=450nm_dRib=25nm_S=650nm.lms (288.5 KB)

thank you for your answer.


#9

Hi @flore.h,

Sorry for the delay, it looks like we missed this discussion!

Although they use the same solver, the FDE solver of MODE Solutions and the mode source of FDTD Solutions behave a bit differently when it comes to the boundary conditions.

First, by default, both solvers are using metal boundary conditions. If in MODE, the BCs are set in the FDE objects, in FDTD, the mode source uses specific BC you can modify in the mode selection window:

In the “Boundary conditions” tab, you first need to check the “override default boundaries” box, and then you can select the BC:

Another difference is the way the solver deals with the structure when it ends where the BC starts. In your simulations, the physical structure has the same width as the FDTD and FDE region. In MODE, the structure is actually cut, as you can see in the screen capture you posted:

You can see the outline of the structure, and you can see the side limits of the structure.

In FDTD, it seems the structure is extended through the PML (like it would continue infinitely in the x direction). If you increase the size of the FDTD region and the mode source, the modes found will be similar to the ones found with MODE.

That said, this would be equivalent to a structure cut laterally, and that might not be what you want to model.

If you consider a structure where the waveguides are etched on a Si layer (the layer extends through the simulation BC), it would be useful to do some convergence testing to optimize:

  • the simulation size: since the modes are quite leaky in the x direction, you may need to increase the simulation size)
  • the mesh size

This could be done for individual waveguides as well as coupled waveguides, and would allow a better understanding of the modal characteristics, loss, mode profile, index and help to get an idea about how large the simulation region should be to get a physically reasonable result.

Finally, this could be done on both products so you can compare the results.


#10

Thank you for your answer,

For now I just have a question about the first point you made.
I can’t find any “Boundary conditions” tab in the mode selection window :

So far, it seems that mode source used the simulation BCs, which were set as described in the topic.

Do you know if there is a way to override those BCs ?


#11

My bad, this feature was added in the 2016b release (FDTD v8.16), so I guess you have an older version. You can download the latest version on our website.


#12

Hi,

I downloaded the latest version and modified the BCs in the “Boundary Conditions” tab to all PML , and I obtained negative effective indexes and additional losses as shown in the following :

For comparison, here is the result obtained by not checking the “override default boundaries” box :

The module of the effective index seems to be the same. Do you know why is there a change?
Also how do I choose the PML settings in this case?
Here is the concerned file :
WG7_dRib=75nm_S=650nm_C=367cm-1.fsp (290.5 KB)


#13

Hi @flore.h,

I think this is related to this note in the FDE solver documentation page:

The FDE solves an eigenvalue problem where beta2 (beta square) is the eigenvalue (see the reference below) and in some cases, such as evanescent modes or waveguides made from lossy material, beta2 is a negative or complex number. The choice of root for beta2 determines if we are returning the forward or backward propagating modes. By default, the root chosen is the one with a positive value of the real part of beta which, in most cases, corresponds to the forward propagating mode. However, we know that a waveguide will not create gain if the material has no gain. To ensure that the correct forward propagating modes are reported, the FDE may flip the sign of the default root to ensure that the mode has loss (and a negative phase velocity) which is physical. Detailed settings can be found in Advanced options.

That said, I’m not too familiar with the advanced options mentioned in the note. I will ask if a colleague can check this point.


#14

Dear @flore.h

Sorry for the wait.

FDE and mode source in FDTD should give you identical results. I can think of a few reasons why the mode profile in these two solvers might be different:

  • Mesh: If you are using different mesh in two solvers, specially for critical geometries such as etched regions in your structure that need a fine resolution, you might get different results.

  • Material fit: If the material fit in two solvers are different, you might get slight difference. In FDE, which is a frequency domain solver, software uses a linear interpolation on experimentally measured permittivity data. If you wish to use identical material fit in both tools, you can force the software to use multi-coefficient model. For more information and on how to do this, please refer to these two pages:
    https://kb.lumerical.com/en/pic_passive_dispersion_analysis.html
    Some tips for sweeping single frequency simulations

  • Boundary conditions: By default, FDE and the mode source in FDTD solver use material BCs to calculate modes. Metal BCs are fast, and are preferred to PMLs. A very good discussion on why metal should be chosen is provided here:
    https://kb.lumerical.com/en/index.html?ref_sim_obj_starting_with_metal_bcs.html

Please note that mode source object has its own BCs (as @gbaethge explained on earlier post) and will override the FDTD BCs. PML boundary conditions in FDE solver are used mainly for bent waveguide calculations. When PML is used, your mode might interfere with PML layers which will results in some nonphysical behavior such as negative mode index in your simulations.

If you want to get identical results in both tools, you need to check the above mentioned factors. Also, if you want to get precise results, you will need to perform convergence test. In your case, since your mode is not decaying enough before reaching BCs, you will need to extend it specially in the x-direction. You want to make sure the mode index does not change with mesh accuracy or simulation/mode source region.

I hope this was helpful