Microsoft Visual C++ Runtime Library error

error
device

#1

I’m doing a sweep where I lower the distance between spherical holes in my device. 2.5um works fine but below this distance (<2.5um spacing for spheres with 1um radius) I get this error. Ideally I would like to simulate this model with the spheres touching.
I believe I read somewhere that Lumerical DEVICE struggles sometimes with spherical objects. Is this the case here? Any solutions?


#2

It looks like that it might be a geometry building issue. Have you tried running the simulation with the same setting separately and not as a part of a sweep? If you can share the file with me then I can take a look and try to figure out what the problem is.


#3

Hi, @llangouc, I am facing the same error with you. Did you solve the problem? If you do, could you tell me how to solve it? Thank you very much!


#4

Hi. In the previous case it turned out that the geometry builder of DEVICE had problems with creating the structure. Unfortunately solving this is not trivial and may require lots of trial and error. If you can share your file with me then i will be happy to take a look.


#5

Thanks for your reply! Since my file is too big to upload, I can only upload some screen shots. I’d like to calculate a PIN with nanoparticles on the surface. The radius of the sphere is 20nm, the PIN is 300nm in x direction and 180 in y direction. In z direction, P(InAsP)1μm, I(InGaAs)3μm an N(InP)1μm.





If more details are needed please contact me. Thank you!


#6

Sorry for the late reply. The first thing to try is to switch to “Algorithm 2” in the mesh tab of the solver region properties. This is always the better option in a 3D simulation with complex design. Please check out this post (Geometry building issue in 3D simulation for DEVICE) for some other suggestions. If you still have problems please let me know.