Method to skip "Updating mode source"?

script
fdtdsolutions
save

#1

Hello all,

Using the scripting interface in FDTD Solutions, I am generating a number of simulations to be run on a cluster. Since these are of large size and the mode source must be updated before each save, the whole process takes a while. Is there a way to skip the mode source update and instead perform this calculation before the file is run (on the cluster)?

Thank you,
Thomas


Ring Resonator sweep Run issue
#2

Dear @thomas.hoekman

One way to stop software from updating mode profile in port tab is to uncheck the “auto update selected modes” box:

The problem is that mode profile will not get updated before running simulations unless you have the box checked.

Can you please send me the simulation file so that I can examine it more?

Thanks


#3

Thanks for the response @bkhanaliloo! Indeed this is the issue I’m facing. I’d like the mode to update, but only when I run it on the cluster.

Here is an example file:

example.fsp (5.3 MB)


#4

Hi @thomas.hoekman

Thanks for the simulation file.

I assume you do not have the CAD license on cluster otherwise you could directly run simulations there rather than your PC. If this is the case, unfortunately there is not much that we can do. Engine license is meant to run the simulation files as they are saved and if the “auto update selected modes” box is unchecked, it will not update the mode source.

The only options would be to perform the sweep in a faster PC, or find ways to speed up the mode source updating stage. For example, you can set the number of trial modes to 2 (since you are interested in fundamental TE mode), and search near n=2.25:

Also, decreasing FDTD span in the x and y direction, say 2um on each side, will be quite useful. Using a coarser FDTD mesh accuracy and a mesh override on the middle object will be a great help too.

Sorry that I was not too much of help, but let me know if you had further questions.

Thanks