material explorer


#1

Hi,

I’m trying to design a star coupler on Si. When I check the material model, there is no Si material but “core material, text material” in pull-down list. Can you help me to solve it?

Thank you very much!

Qi


#2

This is an expected behavior of the varFDTD solver when Broadband is selected. In a varFDTD simulation, you will be dealing with effective materials and therefore you dont see the material data of the actual material. You can find more information on this page.

If you would like to see the actual material fit for Si, you could add a FDE solver and check the material explore again. However, the fit in FDE will not be used in a varFDTD simulation.


#3

Hi, kchow

Thank you very much for your reply,but I don’t comprehend ‘Broadband’. I set the source wavelength regime to 0.1 nm. It still shows the same things.

Qi


#4

When varFDTD solver is used, it will be using the core and test material for the fit. The actual material index will be “transformed” to an effective index for simulation. Only the effective indices are used in the simulation.

In the Effective Index tab of the varFDTD solver region, you can choose “broadband” or “narrowband” in the bandwidth option. According to the options you’ve selected, the material will be fitted with a different material model (the link in my previous post has more information). However, you will still see “core” and “test” material, for the above mentioned reason.


#5

Hi,kchow

Thank you very much for your kind reply. No matter which one I choose, it always shows “core or test”。But
I want to see material names instead of "core "“test”,because there are several materials in my design. It’s not convenient to distinguish them.

Qi


#6

You can see the fit of the material used for simulation in the Material Explore. In this case, the material being used is an effective material that is composed of multiple materials from your design. So really it is important to make sure the effective material (core and test) has a good fit. This is why it is not showing the actual material to avoid confusion. And it should not be necessary to fit the actual material for a varFDTD simulation.

If you really need to see the actual material data in the Materiel Explore, one easy thing you could do is to switch the active solver to FDE. But as I said earlier, the fitting parameters will not be carried to the varFDTD solver.


#7

Thank you very much, Kam!