Manual Install of MPI framework on Windows

Turning on Microsoft .Net 3.5 and install MPI framework.

UPDATE:

Lumerical v2019b and higher does not require Microsoft .Net 3.5 framework.

Windows 10 - Microsoft .Net 2.5

On Windows 10, Microsoft .Net 3.5 is installed as part of Windows update.

If you are logged into your domain or active directory, please coordinate with your IT department on how to install this on your local machine.

Install .Net 3.5 by turning this feature “On” from Control Panel.

Control Panel > Programs > Programs and Features > Turn windows feature on and off

Install MPICH2

Install Intel MPI

  • Open the folder intel_mpi_runtime and run the installer, w_mpi-rt_p_2018.4.274.exe.
    image

Install Microsoft MPI

4 Likes