Lumerical Device - define new material


#1

Hi,

I am trying to do a simulation using DEVICE for the application of material patterning and to study the change of resistance.
I tried to define the material of ITO and PEDOT: PSS and then start with a structure like this:

On top is metal anode contact, the red material is PEDOT: PSS and the blue material is ITO, the bottom contact is cathode.
Where the anode acts as a solar generator which generates current and let the current pass through the geometry and test how the geometry will change the resistance.

I used the data from manufacture to create new material of ITO and PEDOT: PSS in DEVICE, but the simulation cannot run when PEDOT: PSS is used. Instead, when the PEDOT: PSS is replaced by air, the simulation works.

Also, can anyone tell me how can I upload my file for modification since it is larger than 8000kb.

Thank you
Daniel


#2

Hi @cw1883
If your file is quite large. You can switch to layout mode and then upload the file. This action will make the file smaller. @aalam Could you please give us some help? Why both ITO and PEDOT:PSS can not work together in the same simulation? Is it a matter of the boundary conditions? Should the boundary conditions change? I believe that something is not set up correctly due to the BC.
Also, @fgomez is there matter of interference between the two materials?


#3

Hi Daniel,

Thank you for sharing the file with me. Looking at the file I noticed that the PEDOT:PSS material has not been completely defined. There was no conduction valley selected which is why the simulation was not working. Another thing I noticed was that the carrier lifetime was set to zero. When I enabled the gamma valley and set the carrier lifetime to 10 us, the simulation worked for me.

Let me know if this solves the problem for you as well.

Kindest regards,

Ahsan


#4

Hi @aalam
Could you please upload the file here, because I didn’t see any file here. The initial topic does not contain any simulation file.

Best regards
Konstantinos


#6

Hi Ashan

Thanks for your help and now the simulation runs.
However, when there is just a planar ITO, if I set the anode voltage a little higher, the simulation crushed.
Like this:

Do you know why this happened? I guess that’s because of the material since if I change the material to some others, it runs again.

Thank you
Daniel


#7

Hi @cw1883, when you increase the value of the bias voltage and the simulation starts to fail, one thing to try would be to use a smaller voltage step (by increasing the number of bias points). However, when I tried a smaller step size even then the solver failed as the voltage became higher. I then noticed that the doping under the metal contact is not uniform. Since you are using diffusion doping objects, the doping density falls near the outer edges of the doping object and as a result there are regions under the metal contact where the doping is much smaller than intended. This is most likely making the simulation diverge. To solve this issue extend the doping objects beyond the edge of the metal contacts so that the doping under the contacts is uniform. Let me know if that solves the problem for you.


#8

Hi Ashan

Thanks fro your reply and I think I have fixed the problem in using ITO.
Now I am trying to introduce another material into DEVICE - PEDOT: PSS.
I have defined the material as a semiconductor with the properties as follows:

Effective mass 0.3/1
bandgap 1.57
permittivity 4.47
work function 5
mobility 1/0.3
diffusion dopping 3e+20
constant dopping 1.3e+15

And making the simulation geometry like this:

diffusion dopping on PEDOT: PSS

However, the simulations cannot begin with the error shown as:

Why this happened? what modification should be taken to solve the problem?
I have sent an email to you with the simulation file attached.

Thank you
Daniel


#9

Hi Daniel. I believe we talked about this in a post above. Please take a look at this:


#10

Hi Ahsan

Thanks for the help and now the simulation works for the unstructured geometry. However, when I tried to simulate the patterned structure, it failed at some of the pattern thicknesses. Attached is the picture shows the details of the error.


Shall I do some modification on the mesh?
The file is too big to be attached here and I returned into layout mode but it still too big to be put here. Is there any other ways can share you with the file?

Thank you
Daniel


#11

Hi Ahsan,

There is another problem here and the error code shows like this:


This error occurs when I make the simulation area larger while the smaller simulation area doesn’t see this.

I have sent you an email with the simulation file attached.

Thank you
Daniel


#12

Hi Daniel, I got your email and have tested the file with the latest version of DEVICE (available here: https://www.lumerical.com/downloads/customer.html). I was able to run the simulation without any issue. Can you please upgrade to the latest version and see if that solves your problem?


#13

Hi Ahsan,

Thanks for your reply and I downloaded the new version and now that error disappeared.
However, when I tried to make the grating deep groove, the software is trying to tessellating but cannot be finished. It shows this message forever. This only occurs when the etching depth is 180nm.

Is that because of the air gap or other setting problem?

Thank you
Daniel


#14

Hi Ahsan

When I tried to simulate the 2D patterning on my file, I got another problem of meshing, which shows as:

Is the problem due to the complex geometry or the mesh size? What should I do to fix it?
The 2D pattern settings are:
ratio of ITO grating is 0.9 and ratio of PEDOT graing is 0.8.
Etching depth varies.

Thanks a lot
Daniel