Low field intensity when using user select mode in varFDTD



When I run varFDTD in MODE with a mode other than fundamental I get very low field intensity at the input from the mode source (of the order of e-33). The simulation results still seem to be correct (transmission etc.) but it is impossible to see the propagation in the movie monitor due to very low field intensity. Is this the way it is supposed to work? Is there a way to visualize the results with movie monitor for non-fundamental modes?




By default the injected mode profiles should have a maximum E field amplitude of 1 regardless of whether the selected mode is a fundamental mode or higher order mode.

Some possible reasons that I could think of for why you are seeing a low field intensity from the movie monitor could be if you have modified the “amplitude” setting of the source, or if the movie monitor is set up to record a field component which is does not match the polarization of the source, or the movie monitor “scale” setting is too high. The “scale” setting is a scaling factor which can be used to adjust the color scale in the movie to make fields appear stronger or weaker as described here:

Hopefully this helps!



Let’s try to reproduce the issue:

  • I open the ring_resonator.lms example from your knowledge base https://kb.lumerical.com/en/index.html?ref_scripts_scripting_language.html
  • the source mode is set to “fundamental” by default there
  • if I run it and plot P of the through port time monitor I get the peak amplitude around 0.006. I can also see a movie.
  • I change the source mode to user select->select mode->calculate modes and pick the first mode with 0 TE polarization
  • if I run it and plot P of the through port time monitor o through port frequency monitor I get the peak amplitude around e-35 and there is no light in the movie regardles of whether I set it to record “electric field intensity” or “magnetic field intensity”


Is it possible that it could be related to the issue described in this post, where you are trying to inject a TM mode while a TE polarization is selected in the solver?



kchow, you are right, that was the problem, thank you! It works fine now.