Issues with MPI

mpi

#1

When I try to run simulation on a file that is over 2GB with MPICH2, I get 100% processor load and the execution stops at Initialization with 0% progress.
When I try to run the same file with Microsoft MPI, the simulation runs smoothly to the end, but finally stops at some point (with no processor load) and does not even let me to use Quit & save, as shown in the screenshot:

Am I the only one getting this issue? Is it possible to avoid it somehow?


#2

Which version of FDTD are you using? Also, do you see this problem with this one particular file or is this happening for any FDTD simulation with memory requirement over 2GB?


#3

Now I am using the latest one - 2016a, but I also had this issue with the previous versions, although I do not remember for which files it occurred back then. This issue happened to me recently at least two times with two different files - lowering the file size below 2 GB (by lowering the mesh region or something else) solved the problem. I am not sure if there were any other files bigger than 2 GB for which the simulation worked.


#4

Hmm. It is interesting. I personally have run simulations requiring larger memory (more than 2 GB) with both the latest and older versions of FDTD and haven’t faced this issue. So, I am thinking it could be related to something else other than the solver. One thing that could be affecting the simulation is if you do not have sufficient space in your hard drive to save the file after simulation. In your screenshot, I noticed that you are running the file from the C drive and if you do not have sufficient disk space then the solver might stop working. Do you think by any chance that could be reason? Even if you have just enough space to save the file, that might not be enough as the operating system would probably want some free space even after the file is saved to run properly.


#5

I think you did not quite understand me. As I said, I had this problem with simulation files (.fsp) larger than 2 GB (of disk space), not files that require over 2 GB of RAM to run.
Free disk space is certainly not an issue here.


#6

This is an unusual issue that I haven’t seen before.
Is there any chance you are using a x32 bit operating system?
The more likely explanation is that it’s something related to your specific simulation. Is it possible for you to share the file? It would also be helpful if you could attach the simulation log files to your post (from both from MPICH2 and MS MPI).
Finally, does it run properly when you don’t use MPI at all? You can do this in the Resource advanced config by enabling the ‘bypass MPI on localhost’ option. Note that the simulation will take longer to run because it will only use a single core of your CPU.