INTERCONNECT sampling rate in optical modulator measured


#1

Hello,
I have an error when using the element optical modulator measured in the MZM setup. The error says: “OM_3: Input port sample rate ‘1.24914e+13’ Hz is the wrong value for ‘port 1’. A ‘1.6e+12’ Hz sample rate was expected.” I couldn’t see this property in the property tree of this element to change the sample rate.
How can I resolve this problem?
Thanks in advance


#2

Hi @reza.maramqartavol,

Are you using an ONA to do the measurement? This error meagre indicates that the modulator are receiving the optical and electrical signal at different sample rates so that it cannot process the data correctly. You can adjust the time domain “Simulation” settings in Root Element and the frequency range in ONA to make sure the time domain sample rate setting and the ONA sample rate setting matches.


#3

Thank you very much. It is solved.
Best


#4

Hi Dr Wang,
I met a similar problem about sampling rate. The error says "Input port sample rate ‘1.0e+10’ Hz is the wrong value for ‘port 1’. A ‘1.6e+12’ Hz sample rate was expected.” "

If I changed the frequency span of ONA as 1600GHz, the problem would be solved.

However, I notice that in your demo example,
https://kx.lumerical.com/t/lcml-thermally-tunable-waveguide-lcml-wg-thermal-1550-2d/2879


ONA frequency range is 100GHz, not 1600GHz, but it can still can work. Why there would be no error in this situation ?


#5

Hi @lishifeng,

That’s because the example file for the thermally tuned waveguide is purely in frequency domain (ONA analysis type = scattering analysis), and the sample rate mismatch error happens for time domain simulation (when ONA analysis type = impulse response).