INTERCONNECT S-parameter file format

Hello,

I am currently using a MATLAB model to obtain a 4X4 S-matrix in order to create a compact model in INTERCONNECT.

For .dat file formatting, I followed the examples provided here:
https://kb.lumerical.com/en/ref_s-parameter-file-formats.html

I want to include a 4-parameter sweep like shown on the web page:

and the .dat file I obtain is this one:
cdcCompactModel_notWorking.dat (10.0 KB)

When I try and load it into INTERCONNECT as an Optical N Port S-Parameter object, I get the following error message:


and the programme crashes.

If However I create a .dat file without the swept parameters, like this one:
cdcCompactModel_working.dat (4.2 KB)
then the N port S-Parameter compact model loads properly in my INTERCONNECT model.
It seems that as soon as a swept parameter (even only one) is introduced, I get the error message and the programme crashes.

Am I doing something wrong?
Thank you
Jon

Hi @jonathan.cauchon.2,

This is actually a documentation problem. The s-parameter sweep file cannot be directly loaded to the Optical N Port S-Parameter element, instead it should be read by script and set the s-parameter. I will fix the documentation and provide you an example of using this file to you in a separate post.

Thank you for bringing this to our attention.

Hi @gwang,

I’m trying to generate dummy .dat file with py and i created the following file sparams.dat (54.7 KB) for 2 port device with 410 points. I’m trying to import it to my optical N port element in INTC but i’m seeing the following error:
image

I doubled checked the file format and against a .dat file with identical number of points and ports generated with FDTD and it is identical. I copied over the dummy data from my generated file to the FDTD generated file and the FDTD generated .dat file seemed to import fine.

Is there hidden metadata in the .dat file that i’m not capturing in my sparameters generation process?

Thanks

edit: fixed, encoding was the issue (changed to utf-8) and end of line character must be /n not /r.