Install Microsoft .Net feature on windows systems

dotnet

#1

I received my new floating license and tried to install Lumerical on a server. The license manager appears to install OK and the license appears to have been activated. However, when I try to install the tools (e.g. MODE), the installer gives me a message saying that .NET framework 2.0 is needed. (I checked the server, it only has .NET framework 4.5.) Do I simply install .NET framework 2.0 then?
Why does it need such a earlier version of .NET, and why no one else mentioned this problem?

Chuan


Microsoft .Net 3.5 framework required
Installation
FDTD.exe is not running
#2

chuan.xie,

Note:

Windows 8 and 10.
Enable the feature from the Control Panel - as shown for Win 7 (manual installation below).
This feature will be installed via windows update.
If you do not have direct access to the Windows update servers, please ask you IT to install this feature through Windows update.

For recent Windows versions, it comes with version 4 or higher.
Lumerical product application requires .Net 3.5. and this version of .Net requires 2.0.

To install the required version, please refer to the following articles:

For Windows 7:

For Windows Server 2012:

Lito


#3

Thanks, Iyap. My server has Windows Server 2012 R2. Let me try to follow your instructions on Windows Server 2012 installation.

Chuan


#4

Please let us know how things work out for us. We look forward to your feedback.
Thanks,
-Lito


#5

Hi Lito,
Thanks for following up. I had to ask IT to install .NET framework 3.5 on the server (because when I tried following your instructions, it asked for source files), then the installation completed with any problem. I tried MODE yesterday and it worked fine.

Regards,

Chuan


#6

We are glad that everything worked out fine for us.
Cheers,
Lito