How to use the remote engine on Linux

I am trying to start a FDTD simulation on remote server on Linux (CentOS 7), which I have succeeded on Windows. I input the right IP and processes in resource configuration. The job launching preset is ‘Remote: MPICH2’. When I run tests, the Local host works well. The software has no response when comes to the remote engine. I have to stop the software and restart it.

The version of FDTD used is 2019R3.

Thanks!

@wuhao107,

Are you trying to run simulations on both your local windows machine and a remote Linux machine at the same time? Similar to the resource configuration shown?

I believe you already created a post for this before?

For the moment, we highly recommend running remotely using the same operating systems.

See: Parallel Computing, for details.

-Lito

Hi lyap,
For your questions,

  1. I am trying to do this all on Linux machines. The local and remote machines are all runing Linux.
  2. Yes, the resource configuration are the same. We directly use IP instead of Hostname.

Is it possible that the firewall block the connection? I use the default setup of system. Shall I change some setup?

@wuhao107,

Please check out the KB page:
https://kb.lumerical.com/installation_and_setup_parallel-computing.html

To summarize the setup:

  1. All machines should use the same version of FDTD.
  2. Store your simulations file on a shared network folder mounted on all remote machine using the same path.e.g /mnt/shared
  3. Setup your passwordless login to all the remote machines
  4. Allow connections between these machines. Check your firewall settings or network security. Check with your IT department.
  5. Open FDTD (CAD/GUI) on local host, change to working directory to the ‘shared network folder
  6. The Run Test button on the Resource Configuration should work with MPICH2.

Hope this helps.

-Lito