How to resolve error message: "Part of the simulation region does not contain a defined material"

errormessage

#1

I am trying to simulate a simple pn-diode in DEVICE. However, when I try to run the solver, it fails and gives me the following error message: “Part of the simulation region does not contain a defined material.” How do I fix this? I have attached a screenshot of the design and the error message.


DEVICE进行电学仿真计算表面有纳米颗粒的薄膜型器件时总是提示“ Part of the simulation region does not contain a defined material”
#2

Hi @qiaozhi. The particular error that you are getting usually occurs due to two reasons:

  1. You may have created a structure but have not defined a material for the structure. It that is the case then you can just choose a material for the structure by clicking the “edit properties” button.

  2. There may be empty spaces inside the simulation region (Device region) where you don’t have any structure; which is the case you have (I’m guessing) from the screenshot you’ve provided. In DEVICE, the entire simulation region must be filled with materials (semiconductor, insulator, and/or conductor). One easy way to solve this problem is to fill the entire simulation region with a background oxide. You can set the “mesh order” of the oxide to a large value so that it will only occupy the empty spaces. Another solution, of course, would be to make your simulation region smaller so that it only covers areas where you have defined materials. However, the later may not be always possible and using a background oxide is probably the more universal solution to this error.