How to define Graphene in normal rectangle or 2D rectangle?


#1

Hi,

I am trying to run the simulation from http://ieeexplore.ieee.org/document/7573642/
The materials used are glass, copper and graphene.

The questions:

  1. I’ve run both models with C (graphene) normal rectangle and 2D rectangle. But I can’t the result for 2D rectangle.Attached are my simulation files sp_film_resonance graphene.fsp (278.2 KB)
    sp_film_resonance 2d graphene.fsp (384.0 KB)
    Please advice.

  2. How to define the structures of 2D rectangle since I only knew the refractive index of graphene?

  3. Or should I try to run design in this model ? https://kb.lumerical.com/en/index.html?nanophotonics.html
    How to use sweep parameter for this example ?

Thank you


#2

Hi
Sorry to inform that I’m new to lumerical so I really appreciate if someone could take a look at the simulation and give any suggestions.

Thank you


#3

Sorry for the delayed reply. I have checked your simulation files and for the 2D simulation, I noticed that the x position of the graphene sheet was not placed directly at the surface of the copper. Once I moved the sheet to x=-30 nm the simulation no longer diverged.

For the case of the 3D simulation, a mesh override region should be placed over the graphene rectangle in order to make sure that the mesh is fine enough to resolve the thickness of the layer. I would also recommend doing some convergence by reducing the dx mesh step size until the results stop changing to make sure the results are accurate.

It’s unfortunate that the paper that you have does not have any additional information about the graphene material in order to set up the conductive graphene material, however you might be able to search for related devices and see if you can find any further information from another paper. There is some more detail about the material models for graphene here:
https://kb.lumerical.com/en/index.html?other_application_graphene_simulation_tips.html

And there is also a video about it here in case you haven’t already seen it:
https://www.lumerical.com/support/video/efficient_optical_modeling_graphene.html

Finally, for question 3, I think you may have pasted the wrong link since it doesn’t link to a specific application example, but if you would like to know more about using the parameter sweep tool, there is a tutorial here:
https://kb.lumerical.com/en/index.html?sweeps_parameter_sweeps.html

Hopefully this helps!


#4

Hi Nancy

Thank you for your respond and support.

  1. I already moved the sheet x=-30 without diverged but the problem is this design failed to sweep. I am trying to compare both designs that will give the same results thought.


    The first design with normal graphene successfully sweep but not for other design with 2d graphene.
    Why there is no result to be defined?

  2. “I would also recommend doing some convergence by reducing the dx mesh step size until the results stop changing to make sure the results are accurate.” -
    Colud you please demo/ show the steps for reducing the dx mesh step size?

  3. Which designs is preferred for usage of graphene material? What are pros and cons of normal and 2d rectangle?

Thanks again for cooperation.


#5

@nurakmar

Regarding the parameter sweep for the 2D graphene file, it looks like no parameters have been set up to sweep and no results are set up to be collected. These settings have to be chosen by the user before running the sweep, and you can choose the settings to sweep and results to collect by editing the sweep. There are step-by-step instructions showing how to edit the sweep and set up the values to sweep and results to collect here:
https://kb.lumerical.com/en/index.html?sweeps_parameter_sweeps.html

For question 2, you can add a mesh override region from the “Simulation” menu in the main toolbar.

When you edit the mesh override region object you can set the x position and span of the mesh override to match the position of the graphene rectangle under the “Geometry” tab of the edit window. In the “General” tab you can type in the value for the “dx” setting to specify the mesh step size you want to use in the x-direction. Ideally at least 2 mesh cells should be used over the thickness of the layer in order to be able to resolve the thickness of the layer. You can do convergence testing by first using 2 mesh cells over the thickness, and increasing to 3, 4, 5, etc. mesh cells until the reflection and transmission results no longer change when you increase the number of mesh cells used over the layer. This way you can make sure that the mesh is fine enough for accurate results.

For question 3, representing the graphene by using the 2D rectangle instead of 3D rectangle is preferred because you don’t need to use as fine of a mesh around the graphene in order to get an accurate result. Since a coarser mesh can be used for the 2D rectangle, the simulation can be run faster and requires less memory to run.

If you need more details please let me know!


#6

Hi Nancy,

Thank you for information. I have run both designs with sweep parameter but I didn’t get the same answer.

and
Can you explain this situation? And why the y axis is exceed >1?

Do have any suggestions or it is possible that I can sweep the thickness for Cu (copper) from 20nm to 80nm instead doing it separately?

Thank you


#7

Hi,

The results look fairly similar. It looks like you might get a smoother plot if there were more points in the sweep which would give a higher resolution along the x-axis of the plots.

The reflection exceeding 1 could be due to reflections from PML or interaction between evanescent fields of the surface plasmon and the PML and this could be corrected by increasing the x span of the simulation region and increasing the number of PML layers used.

Another possible reason could be that there is some resonance and the simulation time is not long enough for the resonant fields to decay. You can check if this was the case by seeing if the auto shutoff minimum was reached, as described here:

If it was not reached, the simulation time setting of the FDTD simulation region object should be increased.

If you would like to sweep the source angle and the thickness of the copper layer, you may consider using a nested sweep like described on this page:
https://kb.lumerical.com/en/index.html?sweeps_nested_sweeps.html

Hopefully this helps!


#8

Dear @nlui,

Thank you. It’s really helpful. :relaxed:


#9

Dear @nlui,

I’ve decide to use a normal graphene design with background index of air, n=1. But there’s a problem when I tried to run the design in a different background such as in water which n=1.33.

The graph should be the same but it’ll be shifted to show the different background index, I guess. Correct me if I’m wrong. Is it right way to change the background? And how can I get a smooth graph?

Thank you for your cooperation.


#10

Changing the background index setting of the FDTD simulation region object to 1.33 should allow you to represent water instead of air.

It looks like the problem might be due to PML reflections which may be improved by using the steep angle PML profile with an increased number of layers, or it might be that the simulation time is not long enough so the simulation time could be increased in the FDTD simulation region object.

If neither of these helps improve the result please feel free to upload a copy of the file and I would be happy to look into it!


#11

Dear @nlui,

Thanks for your support.
I’ve swept the design in different background such as n=1, n=1.33 and n=1.49 but unfortunately I failed to get the significant graph for n=1.49. Here is the file sp_film_resonance 7950 Au Gr.fsp (278.5 KB)

1)Really hope you can look for it and can you suggest the setting adjustment for resulting a correct graph?
2) Can you explain how to define the value of x,y,z for field analysis? is it a must to always 0 nm or is it refer to mesh value?

Thank you in advance for your cooperation.


#12

@nurakmar

It looks like you are working on the same problem in the following topic with my colleague:

To keep things simpler, please continue the discussion in that topic. Thanks for your understanding!


#13