Geometry building issue in 3D simulation for DEVICE

i use example in lumerical that is grating solar cell. when i change the solver geometry to 3d, and did not change other option, there is an error shown,


please help me figure it out!
thanks

Hi. When it comes to creating complex geometries for 3D simulation in DVEICE, the solver can sometimes face difficulties in creating the geometry. This the case you are seeing here. The same geometry works fine in 2D but it is much more difficult to create the geometry in 3D. A few steps that can be taken to solve such problems include,

  1. Use “algorithm 2” for geometry building. This is available in the properties of the solver region (both CHARGE and HEAT) inside the “mesh” tab under “advanced options”.

  1. If that alone does not solve the problem then the next step is to use small overlaps between neighboring geometries (specially the complex ones like the ribs or native oxide layers in this simulation). You can extend the bottom of the ribs inside the silicon substrate which will not affect the final structure but may help with the geometry building.
1 Like

In this particular file, I noticed that the issue is coming from the native oxide geometries. A very simple solution to the problem would to simply disable the native oxide structure group and set the material for the airclad to SiO2. From the simulation point of view this will change nothing (the surface recombination at the interface between the silicon rib and oxide will still be modeled) but it will make the geometry much simpler for the solver in 3D.

1 Like

thank you very much

i find that if i use the modified setup you mentioned, the result will be different.
so, can i use the mesh constraint to deal with the thin oxide layer, or could you tell me some else methods to fix the problem accurately?
thank you!

The result should not vary depending on the modifications I have mentioned. Did you change the material for the “airclad” geometry to SiO2? Ideally, for both of the setups, the top surface of silicon will have an interface with oxide and that should make the results identical. Do you mind sharing the files with me that you used to check the results?

in order to prove your modifications, i used a 2D model.
after running two models, i find out the Jn in charge of results have huge difference.
the maximum uploading size is 10Mb, but my file size is 40MB.
so, could you give me email, i will send my files by it.

Hi. I think the variation you are talking about in the Jn data is just a numerical issue because of the different mesh grids in the two cases. If you compare the current in both cases you can see that they are identical,

When you compare the Jn for the maximum bias you can see that the peak value is different. However, this is due to the difference in mesh as mentioned in the figure.

If you change the max min values of the color bar to plot both the results on the same color bar, you will see that the plots look identical,

1 Like

If you still believe that the results are different then let me know and we can continue the discussion.

A post was split to a new topic: Difference between 2D and 3D CHARGE simulations

For 3D CHARGE simulation, please make sure the simulation region contains all defined materials (no void is allowed, so in this case you may want to make the region comparable (or even smaller) size with (or than) the doping area.

A post was split to a new topic: Error message: Attempting to re-insert same face

Hi Aalam

I have been working on Oxide based heterojunction solar cells. I have used radial doping. Please find the attachment.

I am constantly getting different errors while using device. After reading few post on problems of Lumerical Device in handling 3-D problem, I tried few things such use of algorithm 2 instead of algorithm 1. Use of an insulator as a filling material, etc. It seems that few of these problems are solved but still I am not able to perform simulation and this time I am getting an error “there are no active materials in the simulation region” even when I have defined GaAs as semiconductor.

Hi @vidur.raj, apologies for the very late reply. I have looked at your file and when I mesh the structure I can see that the GaAs, TiO2 and ITO regions are actually getting included in the simulation. The error in running your simulation might be coming from something else. The semiconductors that you have created have not been completely/properly defined. Please take a look at the KX post below to see the minimum requirements your new semiconductor needs to fulfill in order to be used in a simulation.

1 Like

Hi Aalam

Thanks a lot for your reply. I have been making modifications based on your suggestions on knowledge exchange Lumerical. After few changes simulations runs okay for 2-D charge solver till 70 % but then it shows error
“The Drift-diffusion solver encountered a numerical error (4) and was forced to terminate.”

When I try to run in 3-D it shows following errors.

[cid:6a31b0b0-5fa0-484f-967d-8bc1ca2bd475]

I am not sure where am I doing wrong. Can you please help ?

Please find the attached updated device file.


[https://cfl.dropboxstatic.com/static/images/icons128/page_white.png]https://www.dropbox.com/s/q818x35ecd80vmv/Device_6.ldev?dl=0

Device_6.ldevhttps://www.dropbox.com/s/q818x35ecd80vmv/Device_6.ldev?dl=0


Shared with Dropbox

Regards

Vidur