FLEXLM shutsdown every few minutes on macOS Mojave

Hi,

I’m running MacOS Mojave and Lumerical 2020a with a floating license. At first I wasn’t able to use Lumerical with this license until another user told me about the trick to restart the license server. I read on the forum that this is only necessary when the laptop goes to sleep, but for me it happens approximately every 5 minutes, which limits the the kind of parameter sweeps I can do.

How can I fix this issue?

@christian.kettenbei

Check your macOS power saving settings and disable sleep mode.

Is the Lumerical FlexNet license manager running on the same macOS machine? Or you are getting the Floating license from a different license server?

Best,
Lito

Thanks for the quick reply. I disabled my laptops’ energy savings features and it happens every few minutes without the laptop sleeping or hibernating. I did notice that every time the license stops and I want to execute the command: sudo launchctl kickstart -k system/com.lumerical.flexlm, I have to reenter my password for the sudo command. Could that be related and when a sudo password is required again FlexLM doesn’t have the rights to stay active or something like that?

Thanks,
Christian

And I forgot to mention that the FlexNet license manager is running on the same macOS machine.

@christian.kettenbei

Try to check your power saving settings again. If you do not have sudo/root access it might be saved and cannot be disabled.

When you are not able to access the license, before restarting FLexLM,

  1. Send us the screenshot of the error message you are getting
  2. Check the FlexNet dashboard if this is accessible
    FlexNet license manager dashboard

-Lito

I don’t get an error message, but my run script commands are not working and remain at “initializing”. Sometimes re-executing my script works, but usually the only way to get the simulation working again is to close Lumerical, execute the kickstart command and reopen everything.

Here’s the FlexNet screenshot:

@christian.kettenbei

Please send us the FlexLM log files from this macOS installation of FlexLM.

-Lito

Please find the files attached.

Thanks,

Christian

@christian.kettenbei

It shows that the LUMERICL daemon is shutting down at random. .

  • Is there another FlexNet license manager for other vendors on this machine?
  • Is your computer managed by your IT department?
  • Was there any changes done to Lumerical FlexLM after the installation?
  • Is there another application that might be using the ports Lumerical FlexLM is using? Please try to run the following command on Terminal:
sudo lsof -i tcp:8095
sudo lsof -i tcp:27011
sudo lsof -i tcp:42128

And send us the outputs of both commands. Thank you.

-Lito

I didn’t have to install another FlexNet license managers for other vendors on this mac so I don’t believe there’s another one.

Yes, my IT department manages this computer. But I do know of other Lumerical users with the same computer in my institution and they don’t have these issues.

Here’s the output:

sudo lsof -i tcp:8095
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
lmadmin 85478 nobody 6u IPv6 0x35d5d5560c5bbd31 0t0 TCP *:8095 (LISTEN)

sudo lsof -i tcp:27011
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
lmadmin 85478 nobody 11u IPv6 0x35d5d55610e5be71 0t0 TCP *:27011 (LISTEN)
lmadmin 85478 nobody 13u IPv6 0x35d5d5562b4248b1 0t0 TCP localhost:27011->localhost:54368 (ESTABLISHED)
LUMERICL 85481 nobody 11u IPv6 0x35d5d55610e5be71 0t0 TCP *:27011 (LISTEN)
LUMERICL 85481 nobody 14u IPv4 0x35d5d55623a5cb11 0t0 TCP localhost:54368->localhost:27011 (ESTABLISHED)

sudo lsof -i tcp:42128
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
LUMERICL 85481 nobody 10u IPv6 0x35d5d5560c5bc8b1 0t0 TCP *:42128 (LISTEN)
LUMERICL 85481 nobody 27u IPv6 0x35d5d5561ce2fab1 0t0 TCP MT-207156:42128->MT-207156:54370 (ESTABLISHED)
LUMERICL 85481 nobody 28u IPv6 0x35d5d5561ce328b1 0t0 TCP MT-207156:42128->MT-207156:54375 (ESTABLISHED)
launcher 85487 cnketten 13u IPv4 0x35d5d5563e26b801 0t0 TCP MT-207156:54370->MT-207156:42128 (ESTABLISHED)
fdtd-solu 85495 cnketten 23u IPv4 0x35d5d556349b4189 0t0 TCP MT-207156:54375->MT-207156:42128 (ESTABLISHED)

@christian.kettenbei

Thank you for the information.

If this is only happening to your computer, this is not a bug on the FlexNet license manager since it is not happening to all FlexNet installations on supported macOS.

There might be something/settting/configuration on your machine that is preventing/shutting the license manager down after certain period of time. From the log files it is not happening at a constant interval. Also indicates that the heartbeat timeout (checking with the product and license manager for active use) has been reached at different intervals after a restart of FlexLM.

I will also check with our development team to run some tests to recreate this issue.

-Lito

@christian.kettenbei

It seems to be alot of connections on the ports used by FlexLM.

Can we try the following:

  1. Use 2020a R5 version of Lumerical
  2. FlexLM version is also v1.13 (latest version on our website)
  3. Check that the power saving options has been disabled.
  4. Shutdown the machine.
  5. Restart the machine after a few minutes (5-10min)
  6. Check the FlexLM (via the dashboard) if its up and running
  7. Observe if ths issue happens again when you leave the simulation running for sometime. try the simulation example (paralleltest.fsp) from this article. Edit the sweep to make it take longer to finish.

Hope this helps.
Lito

I did steps 1-6 and I can’t connect to the dashboard via a browser or the launcher. I’m getting an error message saying Unable to connect. Should I try the kickstart command now?

@christian.kettenbei

  1. Try to check the lmadmin.log and LUMERICL.log files - go to the end/bottom of the file and look for any error message and why it was not able to start the license manager or the LUMERICL daemon.
  1. Try to run FDTD directly from the terminal and not from the launcher.
    /Applications/Lumerical\ 2020a.app/Contents/Applications/FDTD\ Solutions.app/Contents/MacOS/fdtd-solutions &
    
  1. If you get a license error – attach the screenshot here.

Best,
Lito

I attached both lmadmin.log and LUMERICL.log files. I tried to start FDTD directly from the terminal and got an error. Screenshot also attached.

Did you try to do a clean installation of FlexLM?

For the Floating license error: -15, we have this documented on this article.


Please try the suggestions for Linux and macOS.

Lito

Yes, I deactived the license, moved the FlexLM application folder in the trash, reinstalled the new FLEXLM software and activated the license.

For the floating license error: The hosts file was set up correctly from the previous installation and I rechecked that it is correct.

Please let me know if we should move to the node-locked license if the network license doesn’t work properly.

@christian.kettenbei,

If your macOS machine does not work well with FlexLM and are not sharing the license across different machines/users on our network. I would suggest to test a Node license. You can request for a trial license as shown in this article.

Be sure to deactivate your Floating license once you have the evaluation Node license in place to avoid any conflicts.

Hope this helps.

Best,
Lito

I used the evaluation license before purchasing the Lumerical License and didn’t experience any issues. How can I convert the current network license to a node-locked license?

@christian.kettenbei,

We were looking into the new logs you provided after the re-installation and it still indicates that there is a communication issue with our daemon on ports used by FlexNet.

2020-04-07 15:23:07,163 root Version: 11.14.0.1 build 188424 (2016.08.09-07.15.18)
2020-04-07 15:23:07,165 root.LicenseEngine started without redundancy.
2020-04-07 15:23:07,654 root.Vendor (LUMERICL) started.
2020-04-07 17:19:55,307 root.Vendor (LUMERICL) stopped.
2020-04-07 17:19:55,311 root.Vendor (LUMERICL) ERROR: daemon listen socket (48).
2020-04-07 17:19:55,311 root.LicenseEngine (LUMERICL) exited with status 37. (Communications error) 

Is this the latest version of FlexLM you are using, v1.13 available on our website? If not, please try to install the latest version.

Check if the /etc/hosts file is similar to the one below:

127.0.0.1  <machine_hostname> localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost6 localhost6.localdomain6
<your_machine_IP> <machine_hostname>

@christian.kettenbei
Please try to remove localhost from the ::1 line as shown above.

Another option would be to install FlexLM on another machine running a supported Windows or Linux system on your network and this will act as your license server where all other machines will obtain the license from, rather than using your mac.

Let me know how this pans out?

Thanks,
-Lito