FlexLM License binding to internal interface


#1

A researcher asked to have Lumerical installed on our cluster. The situation I’m coming into is that they also want to use the license server on their laptop. I believe we have a floating license so this should work. However, on the cluster I’m able to pull a license just fine, but outside of the cluster I get:

lmutil - Copyright © 1989-2015 Flexera Software LLC. All Rights Reserved.
Flexible License Manager status on Fri 11/4/2016 13:27

License server status: 27011@xxx.xx.utsa.edu
License file(s) on xxx.xxx.utsa.edu: licenses/LUMERICL/start.lic:

xxx.xxx.utsa.edu: license server UP v11.13.1

Vendor daemon status (on xxx):

LUMERICL: License server machine is down or not responding. (-96,7:2 “No such file or directory”)

So the license is “UP” but the vendor daemon is having problems. If I go to the admin portal on port 8095, the Server Settings tell me the IP address its listening on is the internal, 192.168.x.x address. How do I change it to also listen on the public facing ethernet NIC?


#2

Hi @jeremy.mann,
The client machines should belong to the same network as the cluster’s license manager. Or the client machine trying to check out the license might not have access to the cluster’s license manager or the ports might be redirected or blocked. Error -96 indicates that the Product Application is not able to communicate with the machine running the license manager.

Try to open a browser and check the FlexNet publisher dashboard as discussed here:
https://kb.lumerical.com/en/index.html?install_flexnet_check_license_status.html

By default the Lumerical FlexNet license manager uses the following TCP ports: 27011 and 42128 and HTTP port 8095. More details on the ports used by the license manager can be found here:
https://kb.lumerical.com/en/index.html?install_flexnet_adv_configure_firewall.html