error in sweep

fdtd

#1

Hi everybody

I have some problem in running the sweep, when I finish running the sweep, there is always a message says “the result of individual simulation of “Ex” are different size and could no be saved”.
I tried several times changing the paremeter of the strutre and settings but in vain, could someone tell me what’s happening there?

pillar.fsp (340.3 KB)

Cheers


#2

Hi,
I ran your simulation with the latest version of Lumerical FDTD (v8.16.871), I don’t come across any error. The simulations ran quickly and when I loaded the data from all the files. I was able to get the Ex for the different radius values.

Best Wishes,

Vivek


Sweep parameter for various thickness
#3

Hi. I have seen this error in sweeps before. You get this error when the mesh changes from one sweep to the other. Since your Ex is a function of x and y, to save all of the Ex on the same matrix, the size of x and y need to be same for all the sweep points. Since you are changing the radius of a circle, the mesh may vary depending on the radius. If that happens then the Ex for different radius will be defined on different meshes and the solver will not be able to load them in the same matrix. When you get this error, try to open the individual files and check if the mesh looks different for any one or multiple cases. If this the source of error then you can use a mesh override object to lock the mesh of the simulation region so that when the radius changes, the mesh will remain unchanged.


Sweeping FDTD region and monitor size
#4

Thank you @aalam and @vivek. it’s now working well.