Engine Error for Longer Simulations

Dear all,

For running longer simulations, I get engine error. It does not happen for shorter simulations. I started to check every thing based on the tips given in the following link:

https://kx.lumerical.com/t/how-to-fix-engine-errors-start-here/2522

Every thing works fine based on what is explained in this page. I have the three MPICH2, Microsoft MPI and Intel MPI installed. I edited the resources and used different MPIs to run the example given in the page and some other simpler simulations, and all worked fine. Also, I checked the memory requirements of my simulations, it needs ~12 GB RAM for running, while the computer has 64 GB RAM and no other software are running on the computer at the same time.
Please see the attachments for the details of the errors that I get in job manager.
Any help is appreciated.
Thanks,
Zeinab
Microsoft MPI.txt (506 Bytes)
MPICH2.txt (6.3 KB)

Try top run the example simulations from:


(and our example benchmark simulation file)

Try to run our examples using 1/2 or 3/4 of the number of processes available on your machine.

This might not be an installation issue. Please try to modify your simulation design. or if you are able to share your simulation file please post this on: Solvers and Features > FDTD category.

-Lito

Dear Lito,

Thanks for your reply. I read the information in the two links you shared here and consider all those points in my simulations. Also, I runned the simulation file that you attached and it was completed with no error. I In fact, I moved the simulation file which was stopped on my computer to another computer and it was completely runned without any problem. You may remember that I face engine error for large simulations which demands longer time and more memory. For simpler simulations, I got no errors.

I have updated Lumerical FDTD on my computer and trying to run the same simulation again to see if I face the same problem. Time of simulation is long and it is not finished, fortunately, I have not received engine error yet. I have to wait till the end of simulation, then I will post here if the update of Lumerical FDTD solved the problem.

Sincerely,
Zeinab

@Zjafari,

Thanks for the update. Some things to consider…

What is the difference between this (2nd PC) and the computer where you can’t run simulations?

  • operating system of this computer?
  • CPU & RAM on this machine?
  • version of FDTD?
  • which MPI are you using?
  • have you tried Intel MPI?

How long did it take to run your simulations on the (2nd PC)? Are you running the same simulation? Did it also take long to complete on (2nd PC)?

-Lito

Dear Iyap,

My simulation was completed on my computer without any errors. Updating Lumerical solved the problem.
The two computers are the same in terms of operating system, CPU, RAM, and the MPI used. The only difference was the version of Lumerical on the second computer, it had already Lumerical FDTD 8-21.1933. I have updated to this version too. Also, I re-installed the three MPIs. Thanks for your help and support.

Sincerely,
Zeinab

Glad that the issue has been resolved. :+1:
-Lito