EME solver not running

eme
license
solver
needattention

#1

Yesterday,
I initially made my own 1x2 MMI since I want to see the power development for different widths and then use it to calculate the length. (it will have a slightly different purpose and thus I made my own setup)
However when I tried running it the EME solver didn’t want to run.

So I downloaded the files from lumerical for a 1x2 MMI https://kb.lumerical.com/en/pic_passive_waveguide_couplers_mmi.html
And just tried both running the script on that page and also running the EME by pressing the run button.
Neither worked and it just didn’t want to run, the error I get when running the script is:

Warning: /tmp/scratch/Bob_twinkle/Pix4Life_simulations/MMI_Test.lsf line 2: in run: there was no simulation data. The simulation failed to run.
Error: /tmp/scratch/Bob_twinkle/Pix4Life_simulations/MMI_Test.lsf line 3: emepropagate cannot be used while in layout mode.

It says that there is no simulation data, which is really odd because this is literally the file I got from the lumerical webpage.
I’m using a student/educational license and the FDE solver in MODE solutions is working just fine.
I was wondering what is going on and if someone can help me to solve this ASAP please.

Note: lumerical is installed on a Unix(linux) server on which I do NOT have administration rights


#2

Hi @Bob_Leuven

This is odd. I run the simulation files on a windows machine and they work just fine.
What version of the software are you using? If it is not the latest version (2017a R3 v7.9.1072), please upgrade it from download center.

Since you can use FDE, I feel like this is a version issue. This is being said that I am not a linux expert!

Thanks


#3

I’ll ask ICT here if they can upgrade it to the latest version since I do not have access to the servers myself.

As for the version that I’m currently using it’s
7.8.966


#4

Hi @Bob_Leuven

We had a major software upgrade in 2017a, and some of the features such as the port object will not work with the 2016b.

Upgrading to the new version will be great so that you can use new features and also updated version of the simulation files. However, you might be able to use some of the older simulation file using this direct. These are our archives for 2015b (which should be supported with 2016b). For MMI coupler in 2015b please use this link.

Thanks


#5

I also met a similar problem. When I run the MMI file, there would be

line 54: in run: there was no simulation data. The simulation failed to run.
line 55 emepropagate cannot be used while in layout mode.

The script is

Could you please help me to solve the problem?


#6

Dear @lishifeng

Sorry for any inconvenience.

I ran the simulation file from this direct and it worked just fine for me. Can you please elaborate more on which simulation and script files you are using? Also, what is the version of your software?

Thanks


#7

Please find the file in the attachment.
MMI_sweep.lms (431.7 KB)

When I clicked the button “run”, it would report an error, However, the same file can work well in my notebook. The version of mode solution is
image


#8

Hmm, this is confusing. I have the same version, but it is working fine:

Can you please reinstall your software? Same versions should behave identical, and this is very confusing.

Please keep me updated, and hopefully we can figure it out.

Thanks


#9

Hi @bkhanaliloo!
I have a similar problem, like @Bob_Leuven.
I downloaded the file from here https://kb.lumerical.com/en/pic_passive_waveguide_couplers_mmi.html
and tried to run it, but I did not get anything done.
I use MODE SOLUTION: Release: 2018b, Version 7.12.1703
on Windows 10 (64 bit).
I reinstalled MODE SOLUTION and this did not solve the problem.

I will be happy with your help.


#10

Hi @krutov13

Can you please explain what happens after you run the simulations? Does simulation show that it is in run mode?

If you want to see the results in the monitors, you need to click on eme propagate button on EME analysis window to populate monitors with data.


#11

Hi @bkhanaliloo

When I run the simulation file, nothing appears on the screen. The window EME analysi does not appear and the button eme propagate is not active.

When I enter in Script Prompt >run;
appears: Warning: prompt line 1: in run: there was no simulation data. The simulation failed to run.
When: >emepropagate
the following message appears: Error: prompt line 1: emepropagate cannot be used while in layout mode.

Below, I’m attaching a link to the video recording from the screen:


#12

Hi @krutov13

Thanks for sharing the video. That was very helpful.
I will share this with our team and will keep you updated with the outcomes.

Thanks for your patience.


#13

Hi @bkhanaliloo
Thank you for responding.


#14

Hi @krutov13

I discussed the case with our team and we had a question for you. A potential problem can be because you do not have the write permission in the directory where the file is downloaded/saved. Can you please make sure that you are saving the file in a directory with read/write permission. You can also try to use another product and see if you still have the same issue.

If this does not solve the problem, can you please give us your system configuration and OS and any other details that you think might be useful.

Thanks


#15

Hi @bkhanaliloo

All other files that I upload to the download folder are launched. This folder does not require special access, the folder is not protected from reading or writing, and administrator rights are not required. When I run a MODE SOLUTION program as an administrator, it does not solve the problem.

My laptop has the following characteristics:
operating system: Windows 10 pro, version: 1803
memory: 8 GB DDR4 2400 MHz
graphics: Integrated Intel® UHD Graphics 620
processor: Intel Core i5-8250U CPU @ 1.60GHz.


#16

Hi @krutov13,

Is there any simulation log file? I assume no, but just in case.

I would also recommend to run the engine directly on that project via command line and save the output to files, to gather more info. Namely in Windows cmd shell:

“C:\Program Files\Lumerical\MODE\bin\eme-engine.exe” MMI_simple.lms 1> MMI_simple.stdout.txt 2> MMI_simple.sterr.txt

and I would be curious to see what these text files have.

Thanks


#17

Hi @bkhanaliloo,

Yes, you are right, the log file is missing.

I run the next line:

C:\Program Files\Lumerical\MODE\bin\eme-engine.exe” MMI_simple.lms 1> MMI_simple.stdout.txt 2> MMI_simple.sterr.txt

and got the following files:
MMI_simple.log (2.5 KB)

other two files can be found here:

I noticed something when watching the configuration of resources:

Thank you for your reply.


Problem with running varFDTD
#18

HI @bkhanaliloo

Thank you for responding. I solved my problem (the main thing is to ask the right question ;-)). It was necessary to change the MPI to the MPICH2.


#19

Hi again @krutov13

Thanks for updating us and I am glad your problem is resolved. A few questions if you do not mind to answer:

  1. What MPI version have you installed?
  2. Can you please provided a screenshot of the Resources > Resource Configuration > Edit > Resource advanced options panel.

Thanks


#20

Hi @bkhanaliloo

  1. In order to find out the version of MPI, I opened the folder C:\Program Files\Microsoft MPI\Bin
    and looked the properties of mpiexec.exe: file version: 6.0.12436.10.