EC2 installation using Amazon Linux AMI

Hi,

I am trying to run FDTD solutions on an Amazon ec2 Amazon Linux AMI instance, however I don’t seem to be able to install all the necessary libraries (especially the gstreamer ones) to be able to get it to run. I was wondering if this is a problem you guys have encountered before, and if you have any suggestions on how to get around this problem?

Thanks for your help!

Hi,

Make sure you have superuser (root) access rights to install the GStreamer and other necessary libraries.

Please use the link below for installing the products by using the standard installation process for Linux.
https://kb.lumerical.com/en/index.html?install_linux_install_manual.html

If it still shows the same error, Please find the list of the required dependencies and install them before installing any Lumerical product

Hi Nick,

Based on the amazon AWS EC2 forums from 2013/2014, the Amazon Linux AMI is not based on any upstream Linux project.

We are not sure that this Linux version is compatible with our products and the Flexnet license manager. You might not be able to use the latest version of the Products and Flexnet license manager on Amazon’s AMI. The current or latest versions only support RHEL / CentOS 6 & 7 Linux distributions.

I would suggest using supported Operating System to avoid compatibility issues. We have the list of supported systems on our website here: https://www.lumerical.com/tcad-products/system_requirements/