Doping Silicon using Drude model and NP Density grid attribute?


#1

Hi everyone,

I want to use a doped silicon in my simulations, but I don’t know how to do that exactly in the FDTD.
I have doped silicon in DEVICE, but now I need to use the doped silicon in FDTD and MODE. Is there any other way to make a doped silicon in FDTD or I just have to import it from somewhere?

I searched in this site to find my answer, but unfortunately it wasn’t the same I wanted.

I’ll be glad to have your responses.

Thank you.


How to import NaYF4 doped with Yb^(3+) and Er^( 3+) in FDTD model
#2

Dear @ifariborz

These two links might be useful for your review as well:
Doped vs undoped silicon nanowire
Temperture to index pertubation

Please let me know if you had further questions.

Thanks


Giving a electrical Input (Voltage input) to a Optical ring resonator
#3

Thanks to you dear @bkhanaliloo.
I will try this links, and hope could solve my problem.


#4

Dear @bkhanaliloo
Hi,
I tried the ways you told, but unfortunately I couldn’t make a doped material. I used the index perturbation and did the exact explanations you have mentioned in https://kx.lumerical.com/t/temperture-to-index-pertubation/4509/4.
When I simulate my structure the perturbed Si doesn’t appear in the simulation.
If it is possible I wanted you to help me with this problem and take a look to my structure.
Here is the file:

mode.lms (251.1 KB)

Thank you a lot. :slight_smile:


#5

Dear @ifariborz

I checked your simulation file but could not see any index perturbed material. Can you please double check your attached simulation file? After we introduced index perturbed material, we can use it as material for the structures in object tree.

Thanks


#6

Dear @bkhanaliloo

It was my mistake, I checked my file and then built a new perturbed material with the name of PerturbedSilicon and applied it on the island (the middle rail of structure). I also added the np density attribute.
Here is the charge file for np density and whole file mode solutions. I should mention that when I use this method in FDTD I can witness the changes, and it works for me, but here in the mode solutions I face the problem.
chh.mat (14.6 KB)
mode.lms (270.7 KB)

Thanks for your attention.


#7

Dear @ifariborz

Thanks for doing all the hard work and updating me with the simulation file.

I downloaded your simulation file and ran them. Here are the results:

in FDE:

I created the same geometry in FDTD with perturbed material and used port object with the same geometry as FDE simulation region. Results look identical (except minor changes due to mesh accuracy) as MODE:

in FDTD using port object:

Can you please elaborate more on what was the problem that you were facing? Also, what version of the software are you using?

I was using 2017b 7.10.1245 for MODE and 2017b 8.18.1245 for FDTD. The are the latest release that you can download from here by selecting Beta Release from pull down menue.

Please keep me update and I will be glad to be of a help.

Thanks


#8

Thank you a lot dear @bkhanaliloo, you are a big help.
The problem was the material itself, and I wasn’t able to use it in mode solutions. I uninstalled the mode solutions and re-installed it, and there the problem solved.

Thanks a lot for your attention. :pray:


#9

You’re welcome, I am glad the problem is resolved.

Thanks


#10

I am trying to study the change in amount of light absorbed as a transistor switches from off to on. I have simulated the transistor in device and have acquired the charge concentrations. I then import the dopant density as a np density grid attribute. However, i see no effect on the refractive index or variation in the amount of light absorbed and suspect Soref/ Drude models dont get applied. I am attaching the Device and the FDTD model here, can you kindly help advise. Thank you so much for your help
trial_NP_grid_attribute.fsp (1.2 MB)
my_charge2.mat (717.9 KB)
Test_transistor.ldev (5.9 MB)


#11

Hi @optics

I am not expert in CHARGE transport simulations but there are two concerns regarding your simulation in FDTD:

  1. The geometry in DEVICE and FDTD simulations are not identical. This can cause problems when you import the charge distribution results in FDTD as doping profile will not overlap with proper geometry.

  2. The box under grid attribute name is empty. You need to set the grid attribute under corresponding objects to “np density”:

Hope this was helpful.