Diverging Simulation in FDTD


#1

Hello,

I am attempting to analyze the absorption and scattering characteristics of an array of gallium nanoparticles on a silicon substrate. In the attached file, I have defined all of the structure and monitor parameters, but when I run the simulation, I receive a diverging field error.

Going through the diverging simulation page at kb.lumerical.com/en/layout_analysis_diverging_simulations.html, I have determined that the error is due to dt stability factor. However, reducing the dt stability factor to nearly 0 does not eliminate the divergence. The material fit is also as expected, and the mesh aspect ratio is 1.

Additionally, changing the nanoparticle material does not eliminate the error, so I am fairly confident that the reason for the divergence is that my simulation is incorrectly set up in some way.

I would appreciate any input on how the simulation region I have defined may be causing this error. Thanks in advance.

Ga_NP_base_1.fsp (330.1 KB)


#2

Hi @initiald,

I had a look at the simulation, and I think there is a few issues, related to the wavelength range you defined for the source [10nm - 80nm]:

  • The mesh is way too coarse: you have define a mesh of 5nm, normally, we would set the mesh to a maximum of 6 cells per wavelength to get meaningful results; in the void, that would be a mesh size of at least1.66nm; the default setting in FDTD Solutions (mesh accuracy set to 2) corresponds to 10 mesh cells per wavelength.
  • The material fit seems quite poor and these is no material data for “Ga” on the wavelength range

So to me, the first question is about the source, is its bandwidth meant to be [10nm - 80nm], or is it a typo?


#3

Hello,

Yes, the bandwidth was indeed a typo and should have been 100 nm - 800 nm. Correcting this eliminated the diverging field error. With regards to the mesh, I had previously set the mesh to be this coarse due to the memory limitations of my computer. However, when I am able to access a system with more processing power, I will be sure to decrease the mesh size to obtain more meaningful results.

I appreciate your help.


#4

With the corrected bandwidth, the fit also looks way better. Regarding the mesh, you can start with a coarse mesh as the calculation will be faster. Once you know the simulation is correctly set, you can reduce the mesh size. Ideally, you should do a convergence testing: reduce the mesh size to see at what point the results are converging.