Diverging simulation in FDTD


#1

Hello Sir,

It was really helpful.
I have struck on one more problem.
I am doing simulation in which the propagation direction is 11 micrometer. When I am running the simulation the auto shutoff level is going too high and Lumerical is showing error (Diveging Field). I have gone through all the possible solution given on the website but still I am not able to solve this problem.
I am using SCPML boundaries with 12 layers and auto no-uniform mesh with min mesh step 20nm.
Looking for your reply.
Thanks In Advance
Ravi


Electric field profile for a rib waveguide
#2

Hi,

Typically the suggestions on the diverging simulations webpage should be able to fix the problem, but it sounds like you have already tried the suggestions from here:
https://kb.lumerical.com/en/index.html?layout_analysis_diverging_simulations.html

Were you able to confirm that the source of the divergence is from PML instabilities by running the simulation using metal boundaries in all directions? If so, and you have already tried using the “stabilized” PML profile setting and you are still seeing the simulation diverge, you might attach a copy of your simulation file so that I could check the simulation setup in detail to try to troubleshoot the source of the problem.


#3

https://drive.google.com/open?id=0B9_tr7xvXQVuV1daeTZSVDVoOE0

This is the link of my file. Please let me know when you download the file.

Thank you
Ravi


#4

Hi Ravi,

I tested the file with a reduced z span of 2.8 um in order to reduce the memory requirements. With the reduced z span I was able to reproduce the diverging simulation. However, when I switched the PML profile from “standard” to “stabilized”, the divergence seemed to be fixed. You might want to try it again with the “stabilized” PML profile with the full propagation length to test. The PML profile can be set from the boundary conditions tab of the FDTD simulation region object:

https://kb.lumerical.com/en/usr_pml_reflection4_zoom70.png

One thing to note is that the number of PML layers used by the “stabilized” PML profile is larger, so you need to extend the structure and patterning through the thicker PML region.

Let me know if the “stabilized” PML profile helps.


#5

Thank you very much… it is working well.