Different propagation loss values in Mode Solutions and FDTD simulation


#1

I met a problem in the simulation of multilayer edge coupler.
The structure is from the example https://kb.lumerical.com/en/pic_passive_edge_couplers_final_eme.html

In the Mode Solutions, the boundary conditions are set as PML. The result is

The Ey distribution of mode 1 is

The loss of mode 1 is 9.1e-4 dB/um=9.1dB/cm which seems too large. In my following calculation, this large loss coefficient would lead to a low conversion efficiency.

However, using the same setting in FDTD , the same input mode was chosen. But here the loss is zero.

Two different loss coefficients were gotton when using the same boundary condition PML. Could anyone help me to find where the problem is. Which one is right ?

The files are listed here
Eme.lms (250.2 KB)

FDTD.fsp (309.7 KB)


#2

Hi @baiyanfei
I read carefully the example and the notes from the link https://kb.lumerical.com/en/pic_passive_edge_couplers_final_eme.html
I run the files “Edge_coupler_EME_final.lms” and “Edge_coupler_EME_final.lms” and i found out that the boundary conditions refer to the Eignen Mode Expansion solver (EME). PML boundary conditions does not refer to the Finite Element Eigenmode solver (FDE). Also, i found out that your both simulation files in MODE and FDTD use the FDE solver. You can correct it. Please read the example carefully. You will notice that in Lumerical’s example the FDE solver is not active.


#3

Dear @konslekk,

Thanks for your reply.
However, I didn’t find other other ways to set the mode source in both EME solver and FDTD.
Could you please tell me how to change the setting? I noticed the FDE is not active in the lumerical’s example, but in the EME port the loss coefficient is also very large.

The mode source is chosen as in the link https://kb.lumerical.com/en/pic_passive_edge_couplers_final_eme.html

For port 1, the mode index is


The loss coefficient is 9.1dB/um which is still too large.

The lumerical file with EME solver is listed here.
eme_port.lms (413.3 KB)


#4

Hi
To set active FDE solver, you can click right and select “set active” on FDE. Automatically EME will be inactive. @bkhanaliloo I would like to ask . Is it possible to to set the mode source in both EME solver and FDTD ?
I think that you have to select one of them. Is it correct ?


#5

@konslekk and @baiyanfei

The port objects in EME and FDTD (as well as mode source) use FDE solver to define the mode profile. This means that if you have identical geometry and identical mesh, results should match. You can perform a convergence test to make sure that the loss results that you get from simulations remains the same as you change mesh accuracy.

Please also note that for mode analysis, as a default, we always use metal BCs, which will override BCs in EME and FDTD except if you are using symmetric or periodic BCs. Please refer to this link to learn more:

https://kb.lumerical.com/en/index.html?ref_sim_obj_mode_analysis.html

Yes, in the 2017a release we have defined port objects that you can use to inject mode source. Previously you need to use a mode source from source tab.

Thanks