CPU capacity handling.

fdtd

#1

We have workstation with 36 CPU (core). Whenever, I run even a small simulation, The Lumerical completely sucks the whole CPU capacity. Now, it become even difficult to open a small file in MS office. Is it possible to define the CPU utilization for Lumerical, let say (90 % for Lumerical and atleast 10% reserve for some small work like opening pdf and other small jobs.). So that it does not get hanged. See the screen shot.


#2

Hi, @visvas !

Didn’t you try changing the number of threads manually?
Like described here: https://kb.lumerical.com/en/installation_and_setup_resource_configuration.html
for example.


#3

I think this is to add multiple no of CPU to divide the job into multiple system. But how to control the CPU utilization of the same system , Since we have only one machine. And this machine is a workstation having multiple cores.


#4

I’ve just changed the number of threads in my FDTD simulation manually. It worked all right.
For this, I entered “Resource configuration” and changed the number from the default of 4 to 1:

Please, let me know if it works for you.


#5

Dear @visvas

As @msaygin said, you can specify the number of cores to be used for a simulation. For example, when I was running a parameter sweep, I asked to use 8 cores of my total available 12 cores and use 2 cores for each simulation. It runs 4 concurrent simulations and my total CPU usage never passed 70%.
:

Here is how I set it:

Let me know if you have any further questions.
Thanks


#6

@msaygin and @bkhanaliloo, Thanks it work for me now. :slight_smile: