Confinement factor variation using nested sweep script in FDE solver


#1

Hello I am simulating a SOI ridge waveguide using the FDE solver in MODE Solutions and I would like to calculate the mode confinement factor (the fraction of power of the mode that is in the core region). I know i can get the value from FDE solver. But i want to make a confinement factor map by varying the core width, thickness,etc. Is there any nested sweep script to get confinement factor and the confinement factor map?

Thank you.


#2

Ηι @naimece
Please read the following post:

and this


#3

Thank you @konslekk. Actually i got the confinement factor from the core using a script but i tried to do the nested sweep to vary my waveguide parameter to get the confinement factor map but every time i run the nested sweep i did not get any result in the visualizer.

So, i am planning to write a nested sweep and plot the result using script file. I did write a sweep script for one parameter but i need help to make the nested sweep in script file for two inner parameter.

I have attached my sweep script file for your consideration. Can you also check how can i add the plot command in this script to plot my parameter and result.

Thank you.

sweep_LN thickness.lsf (876 Bytes)


#4

Hi,

I think you should be able to add the nested sweeps by using the “insertsweep” script command described here:
https://kb.lumerical.com/en/index.html?ref_scripts_insertsweep.html

You should then be able to set up the inner sweep parameters and results the same way as was done for the outer sweep. However, if you set up the sweep the same way from the graphical user interface and wasn’t able to get the result, there might be some problem with the setup of the sweep that could still be present if you set up the same nested sweep from the script, so it might be best if you could provide the example file with the sweep where you are unable to get the result to figure out what the problem is.


#5

Hi nlui

i am still facing the same problem. I have attached the file. Could you please take a look? In my file sweep 1 is the nested loop. I always get wrong result using the nested sweep which does not match with the single sweep result.

Thank you.


#6

Nitride_Large.lms (433.8 KB)


#7

Hi,

I checked the sweep and I believe the mistake is that in the outer sweep, the parameter type of the “tw” parameter is set to “Number” instead of “Length”, so this means that it is trying to sweep the value between 0.5-0.8 metres instead of 0.5-0.8 microns. Because of this, it is not able to find any supported modes when you run the sweep.

Please try making the update and let me know if you are still not getting the sweep results.