Concurrent simulation in FDTD

I tried to use the concurrent simulation feature in FDTD. Two computers have the same version of FDTD and in the same local network. The firewall is temporarily closed. In Resource configuration menu, after configuring the IP for each computer, I clicked ‘Run test’ button. The local host passed the test, but the remote one status was Timeout.
What did I miss?

1 Like

@jeromelw,

Please change the job launching from Microsoft MPI to MPICH2.

Refer to this KB article to run FDTD simulations concurrently:
https://kb.lumerical.com/en/index.html?install_win_configure_engine.html

Note:

  • The MPICH2 account credentials registration will require the username and password you used to login to these windows computers.
  • You will require as many FDTD engine licenses as the number of computers running the simulations concurrently.

  • If you are running a simulation not a sweep, concurrently on a local network and not a high speed cluster to increase performance or make you simulation run faster, this will not work. Your local network will instead run your simulation much slower due to the low network bandwidth between computers.

  • Concurrent computing is best used when running parameter sweep or optimizations.

  • But if your simulation requires more memory to run than the installed RAM on 1 machine and using more machines will resolve the memory issue, then you will have to run it using the distributed method, as discussed in this KB page.
    https://kb.lumerical.com/en/index.html?installation__distributing-a-job-across-several_computers.html

  • From the screenshot you provided. You are using an older version of FDTD. Please update your FDTD to the latest version which can be downloaded from our website:
    https://www.lumerical.com/downloads/customer.html

  • The new version of FDTD will require the latest version of FlexNet license manager for floating licenses as discussed in this KX posts:
    Floating Error: -83
    Floating Error: -140

Hope this helps.

Cheers,
Lito

1 Like

Thanks for the reply, Lito. Very informative.

After changing to mpich2, it worked!

Cheers,
J

Glad to hear that this worked out for us.

Cheers,
Lito

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.