Compound element ports disconnecting in INTERCONNECT

elements
interconnect
sparameter

#1

Hello,

I am having issues with an Optical N Port S-Parameter object within a compound element. My procedure is as follows:

  1. From a blank screen right click, select create > compound element
  2. Right click on the compound element, select edit
  3. Navigate to Ports tab and add two ports. Configure as follows:
  4. Hit OK
  5. Right click on the compound element, select expand
  6. In the Element Library tab navigate to S parameters > Optical
  7. Drag an “Optical N Port S-Parameter” object onto the screen
  8. Connect the ports as follows:
  9. In the Element Library tab navigate to Custom
  10. In the main window navigate back to the Root Element, right click on the compound element, and select “Copy to Element Library”. It should now be in the custom folder.
  11. Drag the new element you just created onto the main screen
  12. Right click on the compound element, select expand

I expect to see the ports connected to the S parameter object like in the image above. However, they are in fact disconnected:

I have duplicated this problem on three different computers running Windows 7, Windows 10, and Windows Server respectively. However, when I tried on OSX 10.10 this issue did not occur.

Any insight on this issue would be appreciated.
Thanks!


#2

Hello,
What version of INTERCONNECT are you using? To check >> Help >> about INTERCONNECT
May be that’s an old bug or a very recent one.


#3

Hi @nar4182,

Thank you for letting us know. Indeed as @aya_zaki said, this was a problem in INTERCONNECT 2017a R2 release (v6.5.1057) and it has already been fixed. Please verify whether you are using this version. If so, please update the software to the latest version. You can find the download package here:

https://www.lumerical.com/downloads/

If this is not the version your are using, please comment back and we can have further look into it. :slight_smile:


#4

Updating to the latest version solved the problem. Thanks for your help!