Component library empty.


#1

Hi,

I cannot add ring resonators or gratings to my layout as the object library is empty. Restarting the software does not solve this.

Do you know what I could be doing wrong?

Thanks.


#2

Hi @geza.kurczveil,

This is a strange case. Generally if the elements in the library are missing, it indicates the software is not properly installed, with some missing .dll files. Could you please upload a screenshot of this problem and I can have a look. Another question, are you talking about elements in the primitive element library or in a compave model library?


#3

Hi,

Attached is a screenshot. I did not install the software, so I don’t know if all the correct procedures were followed.

I’m just trying to follow the ring resonator tutorial shown here. One of the instructions is to “Select RING RESONATOR from the [component library]”. Unfortunately, I cannot find any entries in the component library.


#4

Hi @geza.kurczveil
Object library tab
Type: Structure
Category: All

Objects: Integrated optics
Click: Ring Resonator

If you can not see it. In “Category”, select “Integrated optics” instead of “All”.


#5

It’s still empty. I don’t see a single entry in any of the categories, even when I select ‘all’ in the drop down menu on the right.


#6

Any additional ideas? I would like to be able to instance complex components without having to code them from scratch?


#7

This is very disappointing. I was expecting more help.


#8

Dear @geza.kurczveil

This is a bit strange. Did you have a chance to reinstall the software? It looks like this problem has occurred before when people were loosing internet connection, but should not happen with the most recent versions of the software. Can you please go ahead and download the latest version and keep me updated?
https://www.lumerical.com/downloads/customer.html

Sorry for any inconvenience this might have caused you.


#9

I’ll recommend this to the system admin and report back.

Thanks.


#10

We have updated the software, but the issue remains. Do you recommend a full uninstall/reinstall?


#11

Dear @geza.kurczveil

This is strange. I can see that software shows you online but its weird that it does not show the components.

(click on the image to maximize)

We have two resources for the components, online and offline version and based on the internet connection software will choose to use online or offline library. In cases where software can not decide its state, this problem might occur.

Two possible scenario that might confuse the software are a) firewall blocks the software accessing the online resources, b) your internet connection is too slow and software shifts between online/offline mode.

The good thing is that you can set the proxy settings of the software. Consult with IT department if they can fix the problem for you (provide you with some proxy settings so that software can access online resources). If it was not the case, choose a random proxy settings so that software knows that it is in offline mode and thus gives you the offline library:

If this didn’t work please let me know and I am here to help. Also, if you are looking for a specific component, let me know so that I can send it to you.

Sorry again for inconvenience.


Crash when trying to access object library
Crash when trying to access object library
#12

I tried populating the proxy settings with random things but it still doesn’t work.

We are behind a corporate firewall. Our IT department is asking if there is a certain port number that should be open for for online library to work.

Thanks for your help.


#13

One quick question for you: Can you please provide screenshot for the case where you used random proxy? Does it show that you are in the offline mode?

I forgot to mention that after you used random proxy settings, you need to close the software and open it again. Maybe restarting your computer as well.

Thanks


#14

Aha!!! Indeed, I didn’t close the software after filling in random things. But now that I have restarted it, I see all the components in offline mode.

What proxy setting should I use so that the online library works? Our IT department told me that this is something that they cannot tell me - they need this info from you.

Thanks.


#15

Dear @geza.kurczveil

I am glad that finally you have access to the offline version of component library. The offline version gets updated twice a year and it should be very similar to the online version.

To enable software to gain access to the internet, you need to check network configuration and see if you are using any proxy (consult with IT department). Generally speaking, software automatically detects the proxy settings of your internet connection which usually can be accessed from Internet options—> Connections—>LAN settings (but sometime it might be hidden). However it might fail to access this information (for may different reasons) in which you can manually enter to the proxy settings of the software.

The other reason is maybe you are behind a firewall that somehow limits the software accessing internet in which maybe some expert can help you disabling the restrictions.

Overall, our online resources does not require any proxy settings and these are meant to be set based on the internet configuration of every user.

Thanks


#16

If the offline library gets updated twice a year, then it should suffice.

We are indeed behind a firewall, but the machine does have internet access. One thing we could do is to open a specific port on the firewall if Lumerical needs it, but we cannot disable the entire firewall.

At any rate, the offline library will suffice.

Thanks again for your help, I really appreciate it.