code error in modelling heterojunction solar cell


#1

Hi everyone,

And I’m trying first to simulate an heterojunction InP(p+) - TiO2(undopped).

The meshing runs well but I have an error at the initialization :

“C:\Program Files\Microsoft MPI\Bin\mpiexec.exe” -n 1 “C:\Program Files\Lumerical\DEVICE\bin\device-engine-msmpi.exe” “C:/Users/Emeric/Documents/stage/Heterojunction/Heterojunction_InP_TiO2_ideal.ldev”

DESKTOP-VD10RLJ(process 0): The program terminated due to an error: Initialization failed to converge electrostatic potential update.
DESKTOP-VD10RLJ(process 0): Error: there was an unknown parallel error. The error code is 9002, the process number is 0

could you help me on this ?


#2

If you can share the project file, I will be happy to take a look at it.


#3

Hey sorry I just saw your answer!

I can’t upload the file, it’s considered too heavy.
Could you enlight me on the possible origin of : Initialization failed to converge electrostatic potential update ?
Thank you very much!


#4

When the solver starts a simulation, it performs an initialization loop where it solves the drift-diffusion and Poisson’s equation without the internal loops (for the individual solvers) to quickly reach an approximate solution for the first bias point. The error message means that the potential value did not converge by the end of this loop. This can happen if the initial condition results in a potential profile that is far from equilibrium or if there is something wrong with the setup.


#5

Hi, I am facing the same error as above. Could you help me to find out what’s wrong with my model?
16.8.10 PIN.ldev (4.1 MB)
16.8.10 PIN.mat (4.2 MB)

When I import the generation file, the following error appears,

I have tried to adjust the doping and mesh, but it doesn’t work. I really appreciate your help!


#6

Hi. Thanks for sharing the files. I believe the main problem was arising from the doping profile. The way the doping objects were defined, the resulting profile was not what you were aiming for. In the screenshot below I have tried to summarize this by looking at the resulting doping profile,

A second problem is that for some reason, the generation rate data is all negative. I have temporarily fixed this by using a negative scaling factor. However, you should check your FDTD simulation to make sure why the values are negative.

Finally, a suggestion to make the sweep easier for the solver,

Here is the resulting modified file: 16.8.10 PIN MOD.ldev (4.2 MB). Note that I have removed the generation rate to make the file size smaller. When you load it again, make sure to make the scaling factor -1.

When I ran the modified file under dark and illuminated conditions, the I-V looked fine,


#7

It’s so kind of you and thank you for your detailed reply! I have two more questions,
(1) the generation rate data is negative, but I can’t find out what’s wrong with the simulation setup. Could you help me to check the model and find out the wrong settings?16.8.22.fsp (280.7 KB)
(2)When I change the CHARGE to be 3D in DEVICE, it doesn’t work and the following error appears,
the size of the CHARGE is the same as the generation, and I chose the algorithm 2, else settings are same as 2D, so how can I get the 3D result?
Thank you !!!


#8

Hi. The error in the generation rate is coming from the fact that you are using a broadband source whereas the CW generation analysis group was designed for monochromatic source. If you switch the source to have a single frequency then the value of G becomes positive.

Regarding the issue with the 3D CHARGE simulation, based on your screenshot, the problem could be coming from the fact that the mesh is not refined properly. Please take a look at this KX post to see how you can resolve the warnings due to unrefined mesh (How to resolve error message: “The mesh is valid but may not be adequately refined”).